Jump to content
Corsair Community

K70 doesn't work at POST/BIOS


jweaver
 Share

Recommended Posts

I have owned a K70 for years and been happy.. And I was using it with a fairly old ASUS motherboard.

 

One of the only things I didn't like was that it didn't always work during POST and I just accepted that, perhaps as a fault of the MB.

 

I have just changed to a 'new' computer, based on an old, but powerful HP server.. And I was disappointed to see I have the same problem.

 

Its not the end of the world, but its the last problem I need to fix.

 

I set about proving it today and with the help of a USB keyboard, I can confirm that the K70 simply don't work during POST or in the BIOS.. The whole time I am there there is a white light flashing at the top.

 

I have tried moving the switch to BIOS and it doesn't help... So I have given up and will source a seperate USB keyboard for the times I need to get to the BIOS.

 

But its niggling me and I wonder if there is a solution. I know this is a known/legacy problem, but surprised that in 2020 its still a thing?

 

Does anyone have any thoughts? Or should I just stick with another USB keyboard for the occasional time I need to do "maintenance"?

 

Jon

Edited by jweaver
Link to comment
Share on other sites

If you have an older K70 there should be a selector switch on the back of he keyboard next to the USB cable. If you wish to go into BIOS flip that to the BIOS setting and it should work.

 

Tried that and it makes ZERO difference.

 

In my test today, I went into the BIOS with another keyboard.. But my K70 was unresponsive (With a flashing white light) irrespective of switch position..

 

Its only when Windows boots that the flashing light goes out, the key lights come on and the keyboard becomes responsive.

Link to comment
Share on other sites

 Share

×
×
  • Create New...