Jump to content
Corsair Community

MkII certain keys don't work on a mac.


Recommended Posts

K70 MkII RGB

 

Hi all,

 

I know i'm probably flogging a dead horse here, and I'm sure this has been discussed in here before, but none of the solutions I have found work, or fully match what's happening.

 

I have an early 2015 macbook pro, running mojave 10.14.6

 

With the K70 rgb in normal mode (not bios), the keyboard seems to work fine on the login screen, so I can type in my password and press enter.

 

Once booted, many of the keys along the edges of the keyboard stop responding (SHIFT, CTRL, SPACE BAR, BACKSPACE, ENTER etc.)

 

  • I have tried deleting /Library/Preferences/com.apple.keyboardtype.plist and rebooting.
  • I have the latest icue installed, but this doesn't seem to make any difference if it's installed or not. iCue recognises the keyboard and even uploads the on-board settings.
  • I have tried unplugging the usb and plugging it back in, and going into bios mode and back to no avail.
  • The keyboard identifier doesn't work, as it asks you to press the key next to the left shift key, but that's one of the ones that doesn't work.

 

It's weird that it works fine initially at the login screen. Does anyone have a definitive solution? Corsair support just said iCue is a beta and then went quiet. This is what I got:

"We understand your concern, what you have said is normal because the keyboard will only work as a normal keyboard in a macbook, the reason behind this is because it is only compatible with the following platforms PC with two USB 3.0 or 3.1 Type-A ports Windows® 10, Windows 8.1, or Windows 7, which is the same as ICUE."
... Not helpful.

 

Thanks in advance for any advice and help.

Toni.

Edited by turbo_toni
Link to comment
Share on other sites

  • 7 months later...
I FOUND THE ISSUE!!!

 

Turns out, after going through every single app installed on this Mac, this app:

 

USBOVERDRIVE from https://www.usboverdrive.com/

 

...was completely screwing with my keyboard!

 

OH. MY. GOD.

 

Thank you thank you thank you. I would have never figured this out on my own. I've been using that ap for 7+ years and lugging it painfully through every system upgrade. On this system upgrade (Big Sur) I had to drop ckb-next and was very sad until I realized that iCue now exists for MacOS! (It's previous nonexistence is why I needed ckb-next in the first place). But... the keyboard was not working after iCue install, and I thought for sure it had something to do with some security limitations on my machine (owned by my employer). I ran into similar issues getting ckb-next to work long ago. I would have never, ever guessed it was USB Overdrive. I am pretty sure I can find a replacement for the functionality in that app, or even more likely it's probably built in to MacOS by now hopefully (all I was using it for was precise control of mouse accel/sens and button mapping).

 

Thank you! Very few people follow up on their own threads like this when they solve their own problems, but I always make a point to for this very reason. Google led me here neatly with the search "macos icue k70 only lette keys work"... I did not realize until now I had a typo in there. Ironically if I redo the search with "letter" instead of "lette"... it doesn't lead me here anymore! Thank god for that typo.

Edited by The111
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...