Jump to content
Corsair Community

Void Elite RGB Headset - VERY quiet microphone, can't update driver


SnarkyIguana
 Share

Recommended Posts

I recently replaced an old crappy $20 headset with a Void Elite headset which I liked very much, apart from the issues I'm about to get into. From the start, iCue wouldn't recognize it at all, no matter how many different USB ports I tried putting it into. Uninstalled it from device manager and plugged it back in, and it showed up in iCue finally. Attempted boosting the microphone from iCue because friends in Discord "could barely hear me at all" and they had to boost my volume for them all the way up to the maximum. After boosting it from Windows, apparently all was well, until today.

 

Today I discovered that for some reason sound was MUCH louder in my left earcup than my right. I resolved this by uninstalling it from device manager again and plugging it back in. That problem is solved but now the microphone is back to apparently being much worse than it was than when I got it which was already laughably bad. One of the very same friends who heard how it was before just told me that he turned my volume up to max and it was still extremely quiet. I can no longer boost the microphone in either iCue NOR Windows because they both say they're at maximum.

 

I've made a brand new account to talk about it here because maybe over a month ago now I sent in a support ticket and was passed around a handful of CSRs who totally ignored me when I asked them simply for a DRIVER DOWNLOAD. I have a feeling all this will be fixed once my headset is running the current version. iCue says the current version for this headset is v 0.0.1 which is hardly believable. The CSR kept telling me to just boost the volume after I told him many times I couldn't, and in every single email I simply asked for a place where I can manually download a driver because iCue will not let me.

 

TLDR: Headset microphone is so quiet that I may as well not have it. iCue will not let me update the firmware. Customer service rep via email refused to actually help me and marked my ticket solved. Microphone volume in iCue (when it shows up) says it's at max, and so does Windows. Officially moved back to crappy $20 microphone headset because at least it works. Any help on the microphone volume issue or am I really going to have to find a way to return this?

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
 Share

×
×
  • Create New...