Jump to content
Corsair Community

Faulty RGB Controller in 280x case?


Danielw597
 Share

Recommended Posts

Hello!

 

I purchased a 280x case back in Nov 2018 from Amazon, with the case came the RGB Fan Hub Controller. A few days ago two of my fans in port 3 and 4 (top exhausts) of the controller started strobing, and flashing random colours on boot and sometimes about 5/10 minutes after booting too.

 

Never happened before so at first I thought it was the fans at fault but after switching their plugs into port 1 and 2 the front intake fans started strobing. So I think the controller has become faulty?

 

Has anyone experienced this before and can confirm it's a faulty hub, or an issue with firmware on the commander? This controller wasn't purchased individually as it came with the case so I'm not sure how I go about replacing it if possible?

 

Thanks for any suggestions

 

imgur video of the issue

Edited by Danielw597
added imgur video
Link to comment
Share on other sites

More likely one of the fans has gone bad. Try removing one at a time (keeping the fans connected to ports 1,2,3 in order) and see if the problem goes away with one of them removed. If this enables you to identify the bad fan, put it in the last port in the chain.

Note that it could either be the fan that is misbehaving or the one immediately preceding it on the fan hub. The fans operate in series so one bad fan can impact the rest of the fans after it on the fan hub.

Link to comment
Share on other sites

More likely one of the fans has gone bad. Try removing one at a time (keeping the fans connected to ports 1,2,3 in order) and see if the problem goes away with one of them removed. If this enables you to identify the bad fan, put it in the last port in the chain.

Note that it could either be the fan that is misbehaving or the one immediately preceding it on the fan hub. The fans operate in series so one bad fan can impact the rest of the fans after it on the fan hub.

 

Thanks for the suggestion! I wasn't aware they worked in series in the hub so that's a great shout, thanks. Will give that a go in the morning and report back, seems the PC has to be off for some time before the lights freak out again.

Link to comment
Share on other sites

 Share

×
×
  • Create New...