Jump to content
Corsair Community

Corsair Link Not Deteting Devices


Majesticx
 Share

Recommended Posts

Hi please help me... im really desperate

my corsair link is not showing CPU voltages

not CPU temp

not GPU

not Memory

no nothing

only the pump/cooler

i really tried everything to fix it

its started today.... the only thing i did is to clean my PC from dust

with air pressure (compressor)

i tried regedit fix to set value to 0

i tried restarting service of corsair

reinstalling

nothing works !!! and im so mad i dont know whats wrong with it

please guys try to help me solve it

 

this is what i see

https://prnt.sc/sau6hf

Edited by Majesticx
**
Link to comment
Share on other sites

First, Corsair Link is End of Life. But that's not the issue there.

Would you happen to be running Valorant?

 

its not running now.. i dont play it

but it is installed

how is that have to do with corsair link?

 

i tried now to delete valorant completely

and uninstall Link and install it again.... and no effect at all.. its still showing me only the cooler/pump

no memory

no cpu

no nothing

WTFFFFFFF... what the hell is blocking from Link to show this info?!

when it was all OK for years!! until yesterday when i just cleaned the pc

even when my friends install it... any version of LIKNK the old one 4.6 it shows the GPU but nothing more

what happened to this software?!

it was all fine for so long to me... and suddenly its not showing anything

Edited by Majesticx
Link to comment
Share on other sites

Riots anticheat is blocking Corsair Link from functioning properly. You need to uninstall the anticheat "Riot Vanguard" or disable it in the system tray and restart your computer in able to make Corsair Link work again. Same happened to me so i'm not playing Valorant until this problem with Corsair Link and Vanguard is fixed.
Link to comment
Share on other sites

 Share

×
×
  • Create New...