Jump to content
Corsair Community

H80i GT CPU overheat


Kling92
 Share

Recommended Posts

Hi!

I have the H80i GT in my rig since 5 years cooling my 4790k. I just moved to a new household, transporting the computer carefully. However now I suddenly have problems with frequent Blue screens which I now know are because of CPU overheat. When I run the computer at idle the temps stay around 40-50 degrees C, much higher than Before. And when I runt games it goes up to 90-100 degrees and krasches.

Corsair LINK says the pump is running at 3000rpm. When I feel the pump hoses one is really warm and the other is like room temp Cold. The radiator is not warm at all and the air flowing through it is not warmt either.

 

What do you guys Think. Do I need to replace the cooler? Any Point in changing the cooling paste? Anything else? Suck to buy a new cooling unit if it doesnt solve the problem.

 

Thanks

Kristian

Link to comment
Share on other sites

You have a flow blockage. It was probably collecting or building up in a less harmful spot but then broke loose during the move and is now choking the flow. This seems to be a common prelude and the hot hose, cold hose is a classic sign. You can try tapping on the hoses, tilting the case, or in a last desperate measure take it out and shake it. None of this is guaranteed to work and if it does, the results will be temporary. The blockage is still in there and will come back around at some point. You need to replace the cooler, but this might buy you some more time.
Link to comment
Share on other sites

 Share

×
×
  • Create New...