Jump to content
Corsair Community

LL120 Fans Not Lighting Up On New Build


bjurney
 Share

Recommended Posts

I just finished building my first PC the other night but am having some issues with the LL120 fans. I have the 465x case that comes with a Lighting Node Core (Pro?) and I also bought a commander pro as my MB didnt have enough fan headers to run it from the motherboard. I also have an H100i Platinum that came with 2 ML fans. In the LNC, I have the 4 LL fan RGB cables connected to it with the USB going to the Commander Pro with a SATA cable from the PSU and the fan cables going to the Commander Pro.

 

I have the two ML fans connected to the CP as well but the RGB cables are connected into the H100i with a USB cable going to the CP. The 2 ML fans and the Pump light up and I can change them just fine. All 6 fans in the case spin and I am able to control them.

 

The 4 LL fans are not lighting up at all though. However, if I plug them into the H100i RGB ports, they will light up, so I know the issue isnt with the fan. I have tried multiple SATA connections to the LNC including a dedicated one with nothing else on the SATA chain.

 

iCUE sees the LNC and I can interact with it as if I am changing the lights but nothing happens. I have made sure the profile is set to 4 LL fans. I tried plugging the LNC into its own USB port and I still dont get any kind of response. I tried to update the firmware but it says I am already running the most current version. I even tried just plugging in a single fan into Port 1 and tried it with multiple fans, but I get nothing.

 

At this point, I am thinking its a faulty LNC, but is there something I might be missing or something else I could try? I opened a ticket with Corsair, but haven't heard anything back yet (its only been a couple of days), but figured if there was a suggestion I could try, I would love to see what the community suggests.

Link to comment
Share on other sites

 Share

×
×
  • Create New...