Jump to content
Corsair Community

Corsair Void Headset charging issue


Hoofbot82
 Share

Recommended Posts

I have the Corsair Void wireless headset and i've had it for a couple months now, I haven't had any sound or mic issues with it but one thing that has been plaguing me is the cable that came with the headset doesn't charge it. If i plug it in the light doesnt flash at all and if i check with ICUE open it doesnt recognize that its charging either, i have tried this with multiple other cables that I tested on other devices to make sure they work ,and they do, but they don't work on the headset. However I do have a one foot long cable intended for a Vaporesso vape mod that does charge my headset, for whatever reason this cable and only this cable will charge my headset.

 

I have tried searching the forums and on google to see if anyone else has had an issue like this and have found nothing, I have tried resetting the headset and that didn't solve anything. So whenever the battery is low I have to turn it off and let it charge as the only cable that works is only 1 foot long and then use a spare wired headset I have until it fully charges.

 

Any assistance would be greatly appreciated if anyone has any idea about whats going on or has experienced this issue.

Edited by Hoofbot82
Link to comment
Share on other sites

 Share

×
×
  • Create New...