Jump to content
Corsair Community

Crunchy audio after some time of use.


TeuCat
 Share

Recommended Posts

I've had the Virtuoso for a couple months and the problem started about a month ago. It seems to happen ever 30 minutes to a couple hours, there's no consistent timing to it. It'll just start to get all bitcrunched for no reason and I have to restart the headset by swapping modes to wired back to wireless. It just gets annoying when I'm in a Discord call with my friends and I'm essentially deaf and mute for 10 seconds.
Link to comment
Share on other sites

I think what you mean to say is it's completely unacceptable for a pair of $200 headphones.

 

Bingo.

 

When the product routinely fails to deliver an even adequate experience, it's way more than an annoyance.

 

Here's hoping Corsair has the right people on the case to get the issue fixed ASAP.

Link to comment
Share on other sites

I've had the Virtuoso for a couple months and the problem started about a month ago. It seems to happen ever 30 minutes to a couple hours, there's no consistent timing to it. It'll just start to get all bitcrunched for no reason and I have to restart the headset by swapping modes to wired back to wireless. It just gets annoying when I'm in a Discord call with my friends and I'm essentially deaf and mute for 10 seconds.

 

I have the exact same issue. Flipping the switch resolves it sometimes. Completely unacceptable for a pair of $300 headphones.

Link to comment
Share on other sites

Bingo.

 

When the product routinely fails to deliver an even adequate experience, it's way more than an annoyance.

 

Here's hoping Corsair has the right people on the case to get the issue fixed ASAP.

 

Seems like instead they are just doing nothing and hoping we just stop complaining.

Link to comment
Share on other sites

 Share

×
×
  • Create New...