Jump to content
Corsair Community

Problems with Virtuoso RGB


oblivion254
 Share

Recommended Posts

I purchased this headset yesterday and have been having many problems with it. ICUE freezes all the time and doesn't register the headset and when I turn it on/off I get no sound and even though windows detects it it will not play any sound. Earlier ICUE registed two of the same headset, I cannot get the headset to not sound muffled even though I have tried many eq settings and recently I have started to notice crackles in discord audio or even in games.

Some things of note I have the receiver plugged into a little extension that came with my Razer Manowar way back but, that is plugged into my front usb and I have never plugged the headset into my computer directly I have only connected it wirelessly if that matters. The mic is good but the software and the sound inconsistencies are really turning me off of this headset I don't want to have to restart my comp multiple times a day just to make sure my audio works or ICUE is detecting my stuff.

Link to comment
Share on other sites

My mute mic button has also stopped working today, I have installed windows 10 on a fresh hard drive and even reinstalled icue after using the windows installer. This is seriously bumming me out all these issues with the software because I want to like this headset.

corsairbug1.thumb.png.1aad43d243f0fa92963ad59d612e5ddc.png

Link to comment
Share on other sites

If i where you i would disconnect your headset, manually uninstall it's driver, uninstall corsair icue, restart your pc, reinstall corsair icue fresh & then plug in your headset and let it self-install.

Also make sure your audio and video drivers are fully updated.

Link to comment
Share on other sites

If i where you i would disconnect your headset, manually uninstall it's driver, uninstall corsair icue, restart your pc, reinstall corsair icue fresh & then plug in your headset and let it self-install.

Also make sure your audio and video drivers are fully updated.

 

 

This doesn't work, the headset/drivers are just broken.

 

I've done this on multiple computers, my 2 virtuoso headsets still have the same stupid issues both at home and at work.

 

Random audio distortion, cutouts, multiple headsets showing up in icue, mic mute button not working.

 

I have never had an audio product with even one-tenth of these issues.

 

I think I will have to return both of them.

Link to comment
Share on other sites

 Share

×
×
  • Create New...