Jump to content
Corsair Community

Virtuoso mic mute Button not working


Recommended Posts

Hi,

i got the following problem with my new Corsair Virtuoso:

I have installed icue and using it with my other devices to manage all my RGB animations(keyboard, mouse and mousepad). All works fine, but if I connect my Virtuoso with my pc, wireless or with usb and icue is open, the mic mute button does not work, also the speech announcement does not work. If I close icue it starts working as usual (mute button works). I tried to uninstall the Virtuoso, the drivers and icue itself, but the problem is even there. I used google and found only one other forum thread, without any answers, so I would be really thankful, if anyone got an answer for this problem.

 

Thanks! :-)

Link to comment
Share on other sites

  • 3 months later...
I really wish that they did a better job with the Virtuoso's. I jumped at the opportunity to get this headset when it came out because it looked like it was built strong. But now the Mic mute button doesn't work regardless of iCue, USB mode, wireless mode or firmware version. And all 6 latches on the earcups have broken off from wear and tear over the past 10 months (It's stored on a ST100 headset stand in its downtime). Not to mention how much the pad material itself retains oil from oily hair even if you clean it (and your hair :laughcry:) regularly. I'm really disappointed in this product, despite wanting it to be 'The One' so badly.
Link to comment
Share on other sites

  • 4 weeks later...

Let me start out with I made an account just for this. I just got a Virtuoso SE Headset a few days ago and the mic just never muted at all, not on PC, Xbox One, or on my phone. I sent a support ticket within having the headset for less than an hour. This is what they responded with 4 days later:

 

"Good day, sorry to hear that you are having issues with our corsair headset. kindly try to have the headset in USB/Wired Mode Press hold the mute button While holding the mute button switch to wireless mode Release the mute button after 15 seconds. If the issue persists please do let us know."

 

It didn't work for me but I hope it works for others. I'm currently wanting either a new mic or I'm going to have to send it back. The mic works amazing (coming from using a Logitech G933 Artemis Spectrum) The sound is amazing and the comfort is 10/10 in my opinion and I don't want to send it back. I play with large groups, competitively and I stream so the mute button on a super sensitive mic is a MUST HAVE.

Hope a fix comes out soon or we are able to actually buy a replacement at some point.

Link to comment
Share on other sites

  • Corsair Employees

This is some odd behavior you guys are experiencing. On PC when you press the mute on the headset, does the mic LED change red, and does the icon in iCUE change to show it is muted? Does Virtuoso show any errors in iCUE like a red triangle?

 

Let me know which iCUE version, and Firmware for headset and dongle are installed as a reference.

 

 

And all 6 latches on the earcups have broken off from wear and tear over the past 10 months (It's stored on a ST100 headset stand in its downtime). Not to mention how much the pad material itself retains oil from oily hair even if you clean it (and your hair :laughcry:) regularly. I'm really disappointed in this product, despite wanting it to be 'The One' so badly.

 

Have you created a ticket for the broken earcups yet? If not, please submit a ticket and PM me the ticket number. We'll most likely want to have this unit shipped it for our engineering team to evaluate.

Link to comment
Share on other sites

  • 4 weeks later...
  • Corsair Employees

Which version of iCUE and Windows Feature Update are you running currently? You can check the iCUE version in the settings tab, and Windows Update version under OS Build Info in your "Window Update Settings" window. Also try repairing iCUE to see if this improves the behavior:

 

Unplug your USB headphones.

Close iCUE.

Go to your Control Panel.

Click on Programs.

Click on Uninstall a Program.

Right click on CORSAIR iCUE Software.

Click Repair.

Follow onscreen instructions.

Plug headset back in.

 

Be sure to backup your profiles before beginning this process so you don't have any chance of losing them.

Link to comment
Share on other sites

I just bought these and have the same problem. Hardware mute only works when iCUE isn't running.

 

iCUE version 3.33.246

Firmware: 0.17.149

Win 10 Pro: 10.0.19041 Build 19041

 

Forced firmware update did not resolve the issue.

Edited by dirtyrobot
Link to comment
Share on other sites

  • 2 weeks later...

I am having the same issue. the hardware mute button does not actually mute my mic, icue says its muted and the light changes from green to red. but no audio prompt saying "mic off" and the mic still works people can still hear me. i've tried in both wireless and wired mode. it only works when icue is closed i updated icue to

3.34.161 and it did not resolve my issue. in fact it may have made it worse i no longer am able to turn side tone on or off by holding down the button and the audio prompts for that is gone too. i only know that from trying the steps mentioned above about holding down the mute button swapping to wireless and then releasing the mute button after 15sec.

it is rather unfortunate, i need to have icue open, for my custom DPI settings on my mouse as well as button macro's but that means i no longer am able to mute my mic easily

Link to comment
Share on other sites

  • Corsair Employees
I am having the same issue. the hardware mute button does not actually mute my mic, icue says its muted and the light changes from green to red. but no audio prompt saying "mic off" and the mic still works people can still hear me. i've tried in both wireless and wired mode. it only works when icue is closed i updated icue to

3.34.161 and it did not resolve my issue. in fact it may have made it worse i no longer am able to turn side tone on or off by holding down the button and the audio prompts for that is gone too. i only know that from trying the steps mentioned above about holding down the mute button swapping to wireless and then releasing the mute button after 15sec.

it is rather unfortunate, i need to have icue open, for my custom DPI settings on my mouse as well as button macro's but that means i no longer am able to mute my mic easily

 

Try performing a clean install of the software and see if that corrects the issue:

 

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

Make sure to backup your profiles before you start the procedure as they will be deleted in the process.

Link to comment
Share on other sites

Hey Guys, I was having the same issue and updating Corsair ICUE software to 3.34.161, Restarted PC fixed it for my Virtuoso Carbon. I hope this fix your issue too.

 

 

MSI ACEX570 / Ryzen 5 3600x / 16gb HyperX Predator 3600mhz/ RTX 2070 Super ASUS ROG / M2 500gb WD Black / M2 1TB WD Blue/ CORSAIR 465x/ 750 watts Gigabyte /WINDOWS 10 Ver2004 (build 19041.572) / Corsair Virtuoso Carbon

Edited by hsenki
Link to comment
Share on other sites

Hey Guys, I was having the same issue and updating Corsair ICUE software to 3.34.161, Restarted PC fixed it for my Virtuoso Carbon. I hope this fix your issue too.

 

This hasn't worked for me. Hardware mute still doesn't work when iCue is running. :[pouts:

Link to comment
Share on other sites

  • Corsair Employees

Thank you for providing updates on your experiences. I'll provide feedback to our development so we can revisit working on a solution. Also, can you confirm if the following changes the behavior:

 

* Completely close and exit out of iCUE

* Test the headset on a different PC/Laptop

Edited by Corsair Nick
Link to comment
Share on other sites

  • 1 month later...
Thank you for providing updates on your experiences. I'll provide feedback to our development so we can revisit working on a solution. Also, can you confirm if the following changes the behavior:

 

* Completely close and exit out of iCUE

* Test the headset on a different PC/Laptop

 

- Completely closing iCUE resolves the issue.

- I'll test on another PC as soon as I can.

Link to comment
Share on other sites

  • 1 month later...
I recently built a pc for my friend with lots of corsair bits and pieces. The problem he has is with the virtuoso mic. I have installed icue and updated everything. We can chat through steam chat with icue running but as as soon as he boots a game he gets a voice through the headset informing him of muting the mic with no way of umuting. If he exits icue we can boot the game and chat without issue
Link to comment
Share on other sites

  • Corsair Employees

Hi stebod,

 

Have you and your friend tried a soft reset on the headset? Go ahead and send them the following steps. To soft reset your headset:

 

1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

 

Otherwise, I suggest they open a ticket at https://help.corsair.com so our support will take care of them.

Link to comment
Share on other sites

  • 1 year later...

hey guys, heres what ive discovered with my virtuoso SE problem. It depends on where you press the button. It seems that ifdd i try to press the center or front portions of the mic mute button, it does nothing. But if i press the rear portion of the button it will work. hope this helps

Link to comment
Share on other sites

+1 for this issue...

New headset today. Mic mute LED turns red/green as you'd expect. But will always transmit Mic audio whilst iCue is running. All software/firmware up to date.

Massive security risk for me and my line of work. A official Corsair response to this is needed within 7 days or I'll have to return the product. I cannot use this product for work until it's resolved.

Cheers,

RamjetX 

Link to comment
Share on other sites

On 2/27/2022 at 4:12 PM, RamjetX said:

+1 for this issue...

New headset today. Mic mute LED turns red/green as you'd expect. But will always transmit Mic audio whilst iCue is running. All software/firmware up to date.

Massive security risk for me and my line of work. A official Corsair response to this is needed within 7 days or I'll have to return the product. I cannot use this product for work until it's resolved.

Cheers,

RamjetX 

I returned the headset for a full refund.

Unacceptable security risk. 

Link to comment
Share on other sites

  • 2 weeks later...

I really like this headset, but unfortunately also have this issue.

I stream on twitch and need to be able to rely on this button working so I can quickly mute and unmute.

All suggested options above do nothing to get this working so if there is no known fix for this I'll have to return the headset unfortunately.

Link to comment
Share on other sites

  • 1 month later...

Corsair Virtuoso is literally the biggest piece of junk I have ever had the displeasure of purchasing... I had bought one and barely used it, had it for about a month and when I went to plug the microphone into it the entire thing would just shut off every single time it never ceased to fail. I had to send that one back and received a replacement headset. I immediately noticed that the new headset would tell me the microphone was muted and that my battery was dying (my original one never ever did that) but now my new headset (I've literally had for like a couple of weeks now tops!) is already acting up. it disconnected for no reason then reconnected and now it won't say anything when I mute and unmute the microphone it just makes a sound. I never went into any settings or changed anything it just suddenly decided to act up and now naturally I'm worried this thing is on the downhill slope to becoming a pile of garbage like the last Virtuoso I had did. Thanks a lot corsair.... I love your products but this particular one would work better as a dumpster fire. Super disappointed and am probably now stuck with another faulty headset when I should have just returned the first one and got my money back.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...