Jump to content
Corsair Community

H100i RGB Platinum AIO Quiet Mode


Recommended Posts

I recently installed a new H100i Platinum and the quiet mode is very loud. I've seen some other posts regarding this issue and some suggested to have it run overnight. I did this but the noise is still there. Interestingly enough, when I tilt the case back, the noise disappears. I've attached 2 videos, one where the case is upright and one where it is tilted.

 

Do I have a bad pump? Is air just trapped in? Should I RMA?

 

Any suggestions/fixes would be appreciated!

 

Case upright, pump in "Quiet" mode:

[ame]

[/ame]

 

Case tilted back, pump in "Quiet" mode. No noise!:

[ame]

[/ame]
Link to comment
Share on other sites

Hi,

 

I am in the exact same boat as you. I have now had 2 H115i RGB Platinum's both with the same issue. Sadly I think its a design flaw with the coolit pump. I spoke to corsair customer service and they suggested all the usual - shaking the rad, moving the case while the pump is running, running with case on side over night qith pump on extreme etc etc.

 

I have been unable to release the air bubbles from the pump.

 

I am sadly at the stage where I am looking at going with a different brand or getting a noctua. Between me and my father we have had 6 corsair AIO's and all have been fantastic. Would be a shame to have to move away from them.

Link to comment
Share on other sites

Thanks for the reply. Yeah, when I lay the case down flat on it's side there is no noise at all. I guess I could try keeping it that way overnight and see what happens. If that doesn't fix it, I'll RMA. I had an H80i v2 before this and it never made a sound.

 

Just don't understand why tilting the damn case 25 degrees fixes the problem!

Link to comment
Share on other sites

Both of my units did the exact same when I layed them down flat there was no noise. I presume the air buble is rising to the centre of the pump when we do that.

 

I wonder if its just a bad batch? Does yours still make the noise but much less frequent 'ticking' when in balanced mode?

Link to comment
Share on other sites

In balanced mode it's completely gone. There's only an audible hum coming from the pump, which I assume is normal, but no ticking or rattling. On extreme, its a higher pitched hum and somewhat louder. "Quiet" mode is the loudest of the three for sure.
Link to comment
Share on other sites

  • 9 months later...
I have exactly the same problem. Brand new Aio and quiet mode makes exactly the same noise. Whenever i tilt the case for approx 20° the noise disappears. Balanced mode fixes that noise, but balanced mode is too loud!! I want the quiet mode to be quiet. I ordered a replacement unit and hope i dont see the same issue
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...