Jump to content
Corsair Community

Corsair Service Crashing


mackingtosh
 Share

Recommended Posts

Welcome to Corsair, this is on going and has been happening for 2 years. Do not let anyone come and tell you its your machine and this and that. You will find that Corsair does not really reply here and the people that do basically do nothing but blame your machine. I would contact them directly in a ticket to make sure that corsair actually responds. You can scroll down and look at the gigantic thread about this crashing. iCUE is straight up trash....I have had 3 machines and each one of them do this, all different gear in each.

 

I have started the process of removing all corsair and never going to buy the bestbuy trash again. I have a K70, Scimitar, Void headset and 2 water coolers that are sitting in a box...wont even sell them on the used market in fear of this happening to them. I have 1 more water cooler that i am currently using and only able to use it via the default fan curves. If you do a custom fan curve, it will crash the corsair process and it will require you to restart the process.

 

Just to give you an idea on what Corsair does about things like this. You would think they would fix it, but they didnt, they added a button in your iCUE settings to restart the process. Why would they do that instead of fixing? Thats the question.

Edited by Dominat0r
Link to comment
Share on other sites

Hello,

 

I'm having this issue, and it is happening very often here.

 

The service is restarting, and the iCUE app is crashing many times.

 

My iCUE monitor system has:

 

- Corsair Void Pro 7.1 Wireless headset

- Corsair ST 100 Handset stand

- 4x Corsair CMR16GX4M2C3600C18 (32 GB Ram)

- Corsair Hydro Series H80i V2

 

I have already up to dated all the firmware aplicable (for ST 100, most recently) and Void Pro headset. Memory and cooler does are not applicable to this feature.

 

The iCUE is running the last updated version too (by now, it is 3.27.68).

 

Detail: when it happens, it cuts down completely any device hosted on ST 100, and this one is very bad: i have devices plugged in (external hard disk drive, and USB devices, very frequently). I'm afraid if can damage or corrupt data, because it is not unmounting nothing, by crash event, of course.

 

Plus: I notice this have begun since i activated "Windows Spatial Sound" for both ST 100 and the Void headphones. I will turn this off and see if it still happening.

 

If applicable, i can try to get Windows event logs and send them here.

 

Best regards,

Link to comment
Share on other sites

Are any of you running the ASUS plugin for motherboard lighting? I see you both have ASUS boards. I have one as well and if I enable the plugin I get crashes with ICue consistently. If disable the plugin then I have no issues. To disable go into the settings portion and uncheck in the plugin option. Edited by mpoffo
Link to comment
Share on other sites

I have these crashes happening across three machines: two AMD, one Intel. All three running on Gigabyte motherboards.

 

I won't bother to post the appcrash log files...because Corsair reps won't post or look.

Link to comment
Share on other sites

 Share

×
×
  • Create New...