Jump to content
Corsair Community

K63 wireless not working after failed firmware update


St.Georg
 Share

Recommended Posts

Two days ago my keyboard was working fine. I have had this keyboard for over a year now and have had some minor issues that i was able to troubleshoot and get past. Yesterday I go to play a game and all of a sudden its not working wireless. I connected the charging cable and for about 3 to 5 seconds I got movement in game but then it stopped. So i checked iCUE and i had an update. While trying to run the firmware update it stopped working altogether midway and i had to abort the installation so i could retry it. After aborting it i started to get a notification of a Bin file for the dongle when i plugged it in. At that point my keyboard stopped lighting up or even showing the green light to indicate it was charging. So i tried to run a hard reset. (hold esc for ten seconds, turn it on wait a few more seconds then release) and a few other versions ive read to run a hard reset. None of which worked this time. (i say this time becasue thats how ive fixed my issues in the past was with a hard reset). So now im stuck with the device being detected on iCUE. But no function from the keyboard and a constant update that keeps telling me i need to plug in the dongle then have the power on and then plug in the chord to start the update. but upon doing so it just brings up another copy of the device on the iCUE dashboard which then sends me into a loop of repeating the same process. Ive tried older 2.0 ports and my 3.0 ports and different methods but none are working. I hope this isnt the end of this keyboard and i dont really know what to do. ive submitted a ticket but im posting here to see if anyone else could help me figure this out sooner.
Link to comment
Share on other sites

 Share

×
×
  • Create New...