Jump to content
Corsair Community

Cannot access BIOS


Enexion
 Share

Recommended Posts

Hey folks,

 

over the last week I assembled my new Gaming-PC and resolved most of the errors that came with it. However, there's one issue I just can't resolve despite trying to troubleshoot it:

 

 

My Issue

 

I can't access the UEFI-BIOS of my ASUS ROG Strix 570-E Gaming with the Corsair Strafe RGB (First Edition).

Pressing DELETE or F2 does nothing when my PC starts. The Keyboard seems to be going into the BIOS-Mode automatically: The Scroll Lock LED blinks when my PC starts and stops as soon as I see my Windows-Desktop.

 

 

What I've tried already

 

I've switched the USB Configuration of my Motherboard to Legacy but that didn't help. Switching from BIOS into normal mode on the Keyboard while booting doesn't help either and lastly, connecting the Keyboard via USB2.0 using a connector in my PC-Case wasn't working as well.

Only the Keyboard is currently plugged into the back of my Motherboard to make sure that the USB-Passthrough isn't interfering in any way.

 

Using an old Logitech-Keyboard with no additional features works fine on both the USB Ports of my case and the ones at the back of my Motherboard.

 

 

Installed Software/Firmware-Versions

 

My Strafe has Firmware version 3.08 installed, along with iCUE version 3.27.68.

My Motherboard also has the latest version of its UEFI-BIOS installed from the ASUS Website: Version 1407

 

 

Additional Information

 

Another issue that may be connected to this is that I'm not able to save a profile to the memory of my Strafe RGB after soft-resetting it while trying to fix the issue above.

 

Any ideas on how to resolve this issue will be greatly appreciated. Thanks in advance!

 

 

UPDATE 1 - I've seen that other people around here have the same problem of not being able to save profiles to their Keyboard. I resolved this issue by rolling back to iCUE version 3.25.60. Now I can save profiles on my Keyboard again, but I still can't get into my BIOS. The Keyboard persists to go into the BIOS-Mode during POST.

 

UPDATE 2 - Borrowed a Corsair K70 (First Edition) from a friend and that one worked immediately. I've tested every position of the BIOS-Switch and with every one of them I got into my BIOS without any hassle. Afterwards I thought that perhaps my Strafe RGB is faulty, so I borrowed another Strafe RGB (also First Edition or MK1) and it showed the same behaviour as mine does: PC starts, goes into POST → BIOS-Mode gets enabled by the Keyboard → Pressing DEL or F2 to get into BIOS doesn't work.

Edited by Enexion
Update 2
Link to comment
Share on other sites

While researching my issue for the last couple of days I stumbled upon someone suggesting to soft-reset the keyboard on a PC where iCUE isn't installed: It didn't help.

 

After about 4 Years with my Strafe RGB and no progress with this issue I've decided to send it into retirement.

I bought a new K70 MK.2 RGB Low Profile Rapidfire with Cherry MX Speed switches and it worked immediately: I can access my BIOS regardless of Legacy Support enabled or disabled.

 

If anyone has an idea on what could be wrong with the Strafe RGB MK.1 I'd still appreciate to hear from you although at this point I've found a solution that works for me. One last thing I should add: The K70 doesn't enter BIOS-Mode when I start my computer.

Edited by Enexion
Link to comment
Share on other sites

  • 4 weeks later...

Hey,

 

I had a hell of a time getting into my BIOS when setting up my new system yesterday. I tried everything, but only one thing worked... or at least I think it worked.

 

It was either a combination of F1 and scroll lock or the windows key and scroll lock that worked.

 

Also, ensure your keyboard and mouse are connected to USB 2.0s

 

Hope this helps!

Link to comment
Share on other sites

 Share

×
×
  • Create New...