Jump to content
Corsair Community

HS70 Wireless Not Connecting Wirelessly


Maluco
 Share

Recommended Posts

Hello all!

 

I recently acquired an HS70 Wireless, and am running into an issue:

 

The headset works perfectly connected via the USB cable charging if I have the dongle in another USB port, so the light in the dongle is white and the headset works perfectly, no problem!

 

However, as soon as I remove the charging cable from the USB port, the pairing fails and the light starts blinking, and the headset doesn’t turn on, does not reproduce audio or anything.

 

I already resynced and did the pairing again using a paper clip and forced a firmware update, also reinstalled ICUE, and it still doesn’t connect if not using the charging cable.

 

I know the problem is not the dongle as it recognizes the headset and the light stays connected (with all the voice cues) if the charging cable is also connected. And if the dongle is not connected, and I leave only the headset charging, the voice cues are not there, but the bleeps to know if it’s on/off muted/unmuted work.

 

It also does not appear to be an issue with the headset itself, because like I said, all the buttons work when I have it connected on the charging cable (with dongle or not)

 

So what could it be? Am I being a noob with the config or it’s a faulty headset?

 

I replicated the issue with another notebook from another brand and another OS, processor and so on... same result: As soon as I take the charging cable off, the pairing fails and light stats blinking, headset does not respond.

 

Ps: I charged the headset for hours before trying it out

 

Thanks!

Link to comment
Share on other sites

Sounds like you got a defective headset. Might want to look into getting it returned to the retailer you purchased it from since you just got it.

 

That's what I thought!

 

Thanks for the answer, already sent them a message :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...