Jump to content
Corsair Community

iCUE not detecting NoPro or H100i cooler.


mark_the_bawss
 Share

Recommended Posts

Hi - I am using a node pro with RGB lighting strips as well as an h100i. Both are intermittently found within iCUE but I can't get them to continue to recognize.

 

For the h100i - I have been able to see it on occasion when I hook the USB into an external USB port on my case rear.

 

For the lighting node pro - If i unplug and replug the USB after a restart it will recognize for a few minutes but then disappear again.

 

I have:

1. Updated all drivers

2. Plugged in to multiple USB headers on the MOBO and can confirm both work by testing other devices.

Other things.. it's been a battle for about the past week trying to get things working. I can't remember everything at time of typing.

 

If there is some magic bullet there I'd love to hear about it, but can definitely try to trouble shoot more if anyone is willing to help!

Link to comment
Share on other sites

Unfortunately, the most probable reason is the communication between hardware and software through the X570. This has been a commonly reported issue on that platform since launch and there are several pretty long threads with users swapping strategies. The most common solution has been to use an intermediary USB 2 hub between the motherboard and Corsair hardware. For most users this has eliminated the detection issue. NZXT makes an inexpensive one that is a popular choice and for $20 that is probably better than pulling your hair out every time it makes the dreaded device connect/disconnect chime.

 

This is one of the threads. https://forum.corsair.com/v3/showthread.php?t=189994

Edited by c-attack
Added referenced thread
Link to comment
Share on other sites

Thanks so much for your reply. I have been looking everywhere for a solution but didn't realize it was specific to x570. I did see one post that suggests it might be a powered USB issue. Based on that I had already ordered the NZXT internal hub with the molex connector as my next attempt at a fix. It should be here next week so I'll keep you posted.
Link to comment
Share on other sites

 Share

×
×
  • Create New...