Jump to content
Corsair Community

HW presets no longer cycle on K70 MK.2


More_Power
 Share

Recommended Posts

I update iCUE to the latest version and now I can't cycle through any hardware presets on my K70 MK.2 LP keyboard with the profile key or even when selecting it in iCUE. The hardware lighting effect is present but the keyboard doesn't respond. I use to be able to cycle through my own profiles plus the 3 HW. My own work but not the HW. Did Corsair change something?
Link to comment
Share on other sites

I'm not sure why this would happen. You could try to force flash the keyboard firmware and see if that fixes it...

 

I tried that but it didn't work. I even deleted the HW profiles but they come back after reboot. The profile key does cycle the HW profiles when booting into Windows but once iCUE loads the profile key only cycles through my own profiles. So for 3 (HW1, HW2, HW3) presses of the profile key the keyboard is dark which is pointless.

Link to comment
Share on other sites

That’s how it works. When iCUE is running, the profile button cycles through the software profiles. When iCUE is not running (quit, boot, etc) it will cycle through the hardware presets. If you only have one software profile, then it won’t go anywhere.

 

In this last version of iCUE, they have given you the ability to save hardware capable actions, effects, and lighting from within software profiles. This is done in the onboard profiles tab. However, the prior HW profiles (HW K70 LP2) should still be there and also still work so you can see the lighting.

 

There is a moment during most boot cycles when the keyboard goes offline. The lights will go out for that moment and the profile switch will not work during the interim few seconds.

 

Can you be more specific about what you want it to do? I can't tell from the description if you are stuck on one HW lighting (when iCUE is not running), but then in the next post is seems like they are.

Edited by c-attack
Usual predictive text follies
Link to comment
Share on other sites

That’s how it works. When iCUE is ruining, the profile button cycles through the software profiles. When iCUE is not running (quit, boot, etc) it will cycle through the hardware presets. If you only have one software profile, then it won’t go anywhere.

 

In this last version of iCUE, they have given you the ability to save hardware capable actions, effects, and lighting from within software profiles. This is done in the onboard profiles tab. However, the prior HW profiles (HW K70 LP2) should still be there and also still work so you can see the lighting.

 

There is a moment during most boot cycles when the keyboard goes offline. The lights will go out for that moment and the profile switch will not work during the interim few seconds.

 

Can you be more specific about what you want it to do? I can't tell from the description if you are stuck on one HW lighting (when iCUE is not running), but then in the next post is seems like they are.

 

Before I updated iCUE I was able to cycle the HW profiles with my profile keyboard key even when iCUE was running. So for example, I had 3 custom iCUE profiles and the 3 HW profiles. With the profile key I cycled through the 3 custom and 3 HW seamlessly. Now I can only cycle the 3 custom profiles and on the 4th, 5th, 6th press of a key (HW profiles) the keyboard is dark.

Link to comment
Share on other sites

OK, I get it. This is the middle explanation above. In v3.27 we got a change to the device memory saving. Rather than being forced to use the HW profiles as a "save template", you can now do the same thing from any software profile in the Onboard Profiles tab. After you save something from that software profile, it will turn the little SD icon on the right side from "clear" to white to let you know something is there.

 

As part of that change, it appears the existing HW profiles had their lighting moved from the normal "Lighting effects" slot directly into the Hardware Lighting slot in the HW Profile. So if you go down to K70 MP.2 LP 1 and open up the Lighting Tab, it is now empty and it contents moved. That lighting tab in the HW profile would give you a preview of what you would see. The "Hardware Lighting Effects" tab does not and this why they all come up dark.

 

Solutions: You can re-create the lighting effect in the Lighting Effects Tab for your HW profiles or copy it from Hardware lighting to the Library and then back. Then you get your preview back. I am not sure how long we will be able to do it both ways or if the it was intended for the Hardware Lighting Tab to not show a preview. I will forward the concern on. Frankly, I was pretty used to the HW slot method and I knew where all my stuff was. If I start saving hardware effects here and there among my 60 something profiles, I am going to loose them. I hope we get to keep the HW slot method. Those are easy to find.

Link to comment
Share on other sites

 Share

×
×
  • Create New...