Jump to content
Corsair Community

K70 RGB MK2 Does not show up in Icue


Excypher
 Share

Recommended Posts

Hey folks.

 

So My old K70 RGB is a bit worse for the wear and I made the horrific decision to put myself through hell again on yet another run through Corsairs abysmal software and bought a K70 RGB MK2

 

So typically, the keyboard is not recognized in Icue, It wont even register any key presses, The only way to get it to work is to put it in BIOS mode.

 

I've tried every single USB port on my system, I've tried uninstalling and reinstalling USB drivers, I've tried the keyboard in a different computer (that works weirdly) but nothing will get it to show up in Icue and let me modify anything.

 

The keyboard does show up in device manager under other devices, listed as K70 RGB MK2 mechanical gaming keyboard, but I cannot update the driver, windows says it finds the driver, but encountered an issue installing it.

 

Disabling digital driver signature enforcement does not allow this to go through.

 

So, I'm stuck, I've uninstalled the Icue software and reinstalled it countless times, and tried all variety of solutions offered on threads I've found via googling, and I'm at my wits end with this device.

 

Any advice at all?

Link to comment
Share on other sites

 Share

×
×
  • Create New...