Jump to content
Corsair Community

Issues with applications after iCUE update


Tarnien
 Share

Recommended Posts

Today i was creating a new profile for my Scimitar Pro RGB, and a new update for iCUE popped up, i downloaded it and installed it, it asked me to restart my pc, so i did. After the restart apps like discord, microsoft teams were not able to launch, and iCUE deleted itself. I could not uninstall or install any of those programs, so i used Revo uninstaller. Installing still didnt work. I got the iCUE installer to work but it stops at 65% when launching services and actually tells me it isnt able to launch Corsair Services. I looked for a solution in these forums for a solid 4 hours now and i tried everything, i tried deleting register keys, i tried deleting files from appdata, both local and roaming, i tried running the setup program via administrator cmd, i tried restoring administrator powers. Nothing works and i'm getting frustrated. Thanks in advance.
Link to comment
Share on other sites

  • 8 months later...
  • 2 weeks later...
 Share

×
×
  • Create New...