Jump to content
Corsair Community

Corsair Scimitar RGB mouse issue


KingPingz
 Share

Recommended Posts

So i tried this new game Elder Scrolls Online, and figured i wanted to set up my push to talk keybind i used for my other equipment on discord, quickly to realise that it did not want to work at all..

 

I have tried "EVERYTHING" the internet threw at me, made special profiles with an application based profile that react to the EXE used and by god did i check if i did things right "down 6 hours of troubleshooting so far" and no middle way of solving the issue.

 

Wierdly the keybind on the mouse works perfectly outside in discord's active window, but as soon as i activate the Launcher window it does not work, neither does it inside ESO64.exe :confused:

 

I have also tried to completely uninstall the software, and updated the prompted firmware that ICUE suggested me to update..

 

 

This is a returning problem i've found on the internet some people are crying over lack of support for certain games out there. Am i unable to use the mouse with eso ? should i ask for a refund on my corsair purchase ? :mad: :idea:

Link to comment
Share on other sites

 Share

×
×
  • Create New...