Jump to content
Corsair Community

icue causing issues windows 10


BSNB
 Share

Recommended Posts

Installed icue for my K55 and it has been nothing but problems. It causes weird google chrome startup issue; it'l cause the shift key to randomly paste a string of numbers in different field boxs like steam, google, ect.

 

How do I program my g1-g6 withut this pos software? Will never buy Corsair products that require icue again...

 

 

System specs: 7600k, Strix-e 270 mobo, MSI 1080ti, 970 pro nvme, 850 ssd, WD Black HDD.

Link to comment
Share on other sites

Installed icue for my K55 and it has been nothing but problems. It causes weird google chrome startup issue; it'l cause the shift key to randomly paste a string of numbers in different field boxs like steam, google, ect.

 

How do I program my g1-g6 withut this pos software? Will never buy Corsair products that require icue again...

 

 

System specs: 7600k, Strix-e 270 mobo, MSI 1080ti, 970 pro nvme, 850 ssd, WD Black HDD.

 

That was an issue prior to version 3.25.50, what version are you running? The current version you can download is 3.26.95. If all else fails, you can delete the entries from the Action Library (this won't affect your macros).

 

For how to set up macros, watch this video:

[ame]

[/ame]
Link to comment
Share on other sites

That was an issue prior to version 3.25.50, what version are you running? The current version you can download is 3.26.95. If all else fails, you can delete the entries from the Action Library (this won't affect your macros).

 

For how to set up macros, watch this video:

 

That is weird. I'm running 3.25.60 which i downlaoded from the product page and icue says it is the latest version.

Link to comment
Share on other sites

That is weird. I'm running 3.25.60 which i downlaoded from the product page and icue says it is the latest version.

 

That's the same version I'm on. For some reason its listed twice. Looks like it was updated on 3/3/2020 to version 3.26.95.

 

I was having issues with Chrome too. When I uninstalled iCUE, Chrome for some reason took 4-5 seconds to launch, but if I opened a second window it popped up instantly.

Link to comment
Share on other sites

  • 1 month later...
the head set i have is VOID RGB ELITE USB Premium Gaming Headset with 7.1 Surround Sound. had them since last year no problems till this year. since around jan 2020 my discords audio has been super delayed muting my self or when someone joins my discord the delay to let me know could be from 3 sec to 7 sec. and now every 20min my discord audio would turn off cant hear my mates forced to reset discord every 20min. after 4 months i finally uninstalled iCUE and all my problems went away but now in stead i have worse audio quality and i have a 12 button corsair mouse were 7 to 12 type letters instead whats the point in buying a corsair product if in 4 months the issue has not be fixed
Link to comment
Share on other sites

 Share

×
×
  • Create New...