Jump to content
Corsair Community

Corsair Virtuoso RGB problems


Kyumz
 Share

Recommended Posts

Hi, since i bought the Virtuoso i encoutered numerous problems, some of them could have been resolve with update so i waited before doing such topic.

But lately my Virtuso seems bugged, to be sure that this is not iCue, i made a clean install of iCue (following the steps on Corsair website) but it didn't fix my problems.

Problems:

 

First: my Virtuoso seems stuck in wireless mode, it's not detected in USB mode.

 

Second: RGB won't work anymore, doesn't know why.

 

Third: Dongle have an hard time to connect to headset in wireless mode. (i have xbox controller who is wireless too dunno if it mess with headset)

 

Fourth: when i plug the headset i got (in every usb port, i got this, motherboard, front, or usb hub) a message that said that the headset doesn't have enought power or something like that.

 

Fifth: The pairing system for the dongle isn't working on iCue, but i thing it's because the headset is not detected in USB mode ...

 

Last one: can't mute the microphone too....

 

On some topic i saw that the last firmware version are:

Virtuoso headset: v 0.17.149 or later

Virtuoso headset wireless dongle: v 0.15.76 or later

 

In my iCue i don't have those version, even when i try to update the headset it doesn't .

 

Please help me...

Link to comment
Share on other sites

Hi Kyumz,

 

Don't know how much this will help, but it may point you in some direction.

I have Virtuoso SE headset.

Will try to direct per your issues as per my personal experience.

 

1. I assume it is charging, which may seem like a driver/software problem and maybe in a rare case the cable, but keep in mind my comment at the bottom of the reply.

 

2. That's controlled (as far as I know by the iCUE software). Doesn't work meaning it is stuck at the default or you can't change it? If default, I would assume the issues of nr.1

 

3. My one connects fine and I also have a wireless XBOX controller with dongle. Now it points more towards hardware.

 

4. Sounds like a faulty headset and maybe, but very unlikely, the cable.

 

5. As per point 1, I assumed the headset does work with in wireless. So it doesn't work at all then? Or it does but you can't use the controls in iCUE?

 

6. Can't say anything about that since I don't use my microphone... its unplugged.

 

Regarding the firmware... if it can't connect in USB or is detected in iCUE… it would make sense to me that it wont be able to update firmware.

 

Advice, test it on another PC with the latest iCUE and fully updated Windows.

If you have the same issues, I regret to inform you... my last comment.

 

The quality of Corsair's audio products have seriously gone down the drain.

 

* To note, my VOID wired headset lasted quite a while until the wire for some reason, even with careful handling decided to short. So it keeps losing connection and reconnects when I move my head. I decided to get a Virtuoso SE, which I also regret to inform you that despite the reviews is really way under par in sound quality even compared to some non High Fidelity and much cheaper headsets. Then I got a VOID Elite Wireless, which (and this really rocked me in a negative way) had worse sound quality than my original VOID headset (I compared them since the original one still works with careful handling) and can't even charge!

 

Every year the audio product quality goes further down the drain. That's audio from my experience though. In Corsair's defence, my Corsair keyboard, mouse and SSD's are solid performers and worth every penny.

Edited by VoodooTank
Forgot to mantion comparison headset.
Link to comment
Share on other sites

Hi VoodooTank,

So basicly, i can see my virtuoso on iCue, but nothing is working when i change something in it (exept when i update the firmware of the dongle).

I'v tried with many cable and it's not the cable... Since it's still charging the headset but he's stuck on wireless mode.

i don't have another PC to test it on, i'll try a bit later to format my PC...

Link to comment
Share on other sites

  • 2 weeks later...

Hi Kyumz,

 

I opened a support ticket.

After I explained my Corsair Void Elite does not switch on when the cable is unplugged, THREE days later I got a response that this is a common problem with the Void Pro's and I should unplug the cable, switch it on and reset it.

I just explained its a Void ELITE and does not work UNPLUGGED.

Support did not even read the ticket.

 

Maye you have better luck. Let me know how it goes after the format or if you get a chance to test it on someone else's system.

Link to comment
Share on other sites

I opened my virtuoso RGB wireless SE headest Christmas morning. After an hour, I tried to be content using either the USB function OR the bluetooth option. Unit would simply not function either/or. Since then I've tried multiple times to uninstall ICUE and reinstall, following guildelines on the Virtuoso FAQ pages here. I've updated firmware, software, clean installs, windows updates, 7.1/2.1, USB only, wireless only, windows spacial on/off.

The unit is a huge fail. I was once able to get reliable sound/mic for a month straight in USB mode only... then I was tempted to plug the dongle in.. boom, whole thing falls apart again. back to no sound or no mic.

Corsair keeps lying to me with their advertising team, promising amazing products that excite, look good and perform. When i get them, they look good, they feel quality, but they will not perform. My $$$ K95RGB platinum Keys, crashes games, macros cross into other applications and get stuck even after deleting all of my custom profiles, my $$$ flagship AX1200i PSU dead in a year. Corsair you used to be my favorite, but now... your software team sucks soooo bad, nothing is reliable. ICUE gives me more issues than anything else installed across all the drives of my whole PC. The fix is, just throw the headset onto the driveway, and drive over it.

Link to comment
Share on other sites

My issue is that when the headset needs charging the charge light sometimes blinks when its charging as it should, other times it shows solid green light (fully charged) but its not because when put into wireless mode the light flashes red and cannot use unless go wired.

 

Been plugged into USB overnight and still not working next day (red flashing charge light) when try use wireless. Can only use wired. I believe it is charged (because sometimes it just seems to clear itself randomly) but wont register itself as being charged. This has been an ongoing regular issue every couple weeks since bought it about 3 months ago.

 

Tries soft rest as advised by Corsair but not make difference.

 

Have latest firmware etc in iCue.

 

Faulty headset or software issue? Is there a solution?

Link to comment
Share on other sites

 Share

×
×
  • Create New...