Jump to content
Corsair Community

H115i RGB PRO XT Fan issue


gmill
 Share

Recommended Posts

So i've had this AIO for about a week now and it had been performing perfectly. As of about half an hour ago the fans are now running at full RPM no matter what I change in the ICUE software. I was playing Division 2 and had changed the profile of the fans so i was returning them to the balanced settings. Everything was fine for a few minutes and then all the sudden the fans just started running at full RPM. Tried restarting PC, reconnecting the USB to the pump and the connection on mobo and disconnecting the cpu_fan and both fan connections. Nothing has seemed to work. I even tried connecting an unused phanteks fan that i have laying around and it causes that to run at full RPM. Also, the pump is still controllable because i have changed that around from quiet/extreme/performance. Edited by gmill
Link to comment
Share on other sites

That seems like glitch. Two things to try.

 

1) Quit the iCUE app from the system tray. Open Task Manager and kill all the iCUE Corsair services. There are 4 or so that all start with "Corsair _____". Restart iCUE normally. Does control come back?

 

2) Create a quick custom curve and set a fixed RPM. Performance Tab, click +, new curve appears. Select Fixed RPM or %. Make sure you click on the fan RPM readings after creating the curve to apply it. Fan curve is yellow. Fans will ring yellow when applied. Do they respond?

Link to comment
Share on other sites

Thank you for the quick replies! It must have been some sort of glitch like you said. I forced a firmware update on ICue and it resolved the issue immediately. Not sure what was going on but I guess a glitch like you were saying. Ending all corsair tasks in Task Manager could have possibly worked also. I did try changing fan curves and %'s but that didn't work. Forcing the firmware up date did though! Thanks for the quick replies and help!
Link to comment
Share on other sites

I forced a firmware update on ICue and it resolved the issue immediately.

 

OK, I am glad it stopped. However, try not to flash the firmware too often. There is always a small chance you can brick the cooler and that is a royal pain. Seems like it might have been necessary this time, but save that for a last resort and please report back if this becomes a frequent issue.

Link to comment
Share on other sites

It is very unlikely that you encounter an irrevocable problem flashing the firmware on a one time basis. However, if your fans lock up daily, and you flash the firmware daily to fix it, then those small odds grow to become something no longer small. It was more of warning that if the problem continues, we need to find you another solution. Flashing the firmware daily or even every few days is not how things are supposed to work.
Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...