Jump to content
Corsair Community

ICUE Software forces Dedicated GPU Usage


Bealte
 Share

Recommended Posts

Hi Everyone,

 

I'm hoping someone can help me here. My laptop is a MSI GS65 8RF (GPU is a 1070 MaxQ) and for some reason, ICUE activates my dedicated GPU. I've looked through the settings available and I can't figure out why it's doing this. I have the Nvidia setting that shows me what applications are using the GPU, but it shows as inactive. However, my LED indicator light turns amber (which indicates my GPU is active), and my laptop runs noticeably warmer. This also results in a roughly 75% drop in battery life (from usually 7 hours to a little under 2 hours from just web browsing)

 

I've isolated all other issues by doing a clean install of windows. Only when installing ICUE does my amber light turn on and my laptop gets warm. If I uninstall, the amber light goes back to white and temps drop back down.

 

Force quitting ICUE also keeps the amber light on. It's only when I go into task manager to kill Corsair.Service (32 Bit) that my indicator light goes back to white.

 

I've gone into the Nvidia 3D settings and forced ICUE and Corsiar.Service to use the integrated GPU rather than the dedicated one but no dice.

 

I'm unfortunately stuck with using ICUE as my mouse basically loses most functionality without it. Back and forward and option button don't do anything unless ICUE is installed and running, so force quitting Corsair.Service does me no good either.

 

Hoping someone can help me figure this out.

Link to comment
Share on other sites

  • 2 months later...
I have the same issue. I think the hardware monitoring of ICUE causes this but I don't see anyway to disable it. It is really a shame because only solution is uninstalling ICUE and if I do that I lose the audio cues and I can't see the battery status of my Void Pro Wireless. Were you able to come up with a solution?
Link to comment
Share on other sites

  • 3 weeks later...

i had this same problem for a long time, when i play a game it crashes, if i close icue and corsair.service it works fine. but somehow i fixed it disabling it to open on windows start.

u can try it on msconfig. hope it works to easy cpu usage.

http://prntscr.com/sh8snn

Edited by kaiouken
Link to comment
Share on other sites

  • 3 months later...
I've just had the same problem on my Surface Book 3. When I first installed iCUE back in June I don't recall having a problem. Recently I noticed there was an update pending and after updating is when this issue began. The fan on the Surface Book was running almost constantly and the battery usage from iCUE was the second highest app, only behind the browser and only a couple percent for that matter. For now I've saved my profile to my Corsair mouse and uninstalled iCUE until they can fix this.
Link to comment
Share on other sites

  • 5 weeks later...
  • 2 months later...

I have the same issue with my MSI GL65 SFSK when it comes to the corsair service. I even changed so every operation of the icue software is running on the integrated GPU both from the win10 settings and the nvidia control panel yet it causes problem every time it's running.

 

This shows only that the devs of the software need to fix this issue because it's well shown that the software is flawed.

 

How it can run the dGPU and the dGPU can't even tell us is really scary if you ask me.

Link to comment
Share on other sites

 Share

×
×
  • Create New...