Jump to content
Corsair Community

Need help with K57 Wireless and Ironclaw RGB


amk320
 Share

Recommended Posts

Hello all:

 

I needed to replace a keyboard and mouse the other day and have given the above referenced products a try. I'm quite happy with the feel and quality of these items, but the software and the keybindings are literally driving me nuts.

 

I set this stuff up right out of the box and tried to assign some of the custom mouse buttons in World of Warcraft. I can't. Two of them seem to reserved for changing DPI (which I don't need) two more seem to be for custom profiles (which I also do not need) and the remaining three were tied to my 1, 2 and 3 keys for some reason, so attempting to bind them to anything was unbinding 1, 2, and 3 (and outside of game, pressing these mouse buttons was pressing 1, 2, and 3).

 

Then, that stopped. The buttons stopped being tied to 1-3, and I was able to program one of them. The others did nothing and would not register in game.

 

The next day, I was suddenly able to program one of the additional buttons. It now was recognized by the game.

 

Yesterday, despite not changing anything, that second button no longer does anything.

 

Today, the second mouse button is duplicating my A key.

 

Again, I am changing absolutely nothing except occasionally plugging these items in to charge, and unplugging them when they're done.

 

I have not yet tried to use the custom G1-G6 keys on the keyboard yet. But for the first three days I had them, accidentally pressing them in games did absolutely nothing. Today, pressing them duplicates the 1-6 keys on the keyboard and trying to assign them to anything unbinds the 1-6 number keys.

 

What is going on? Why are keys changing and unassigning themselves and tying them to other keys? I feel like these products have a mind of their own.

 

I would've much preferred programmable buttons that are completely unassigned and untied to anything that would let me customize to perform specific actions in game. That's how every other custom key/button on every other mouse/keyboard that's had them has worked.

 

How do I get these things to stop doing this? I don't want these extra buttons tied to any other key on the keyboard. I bought these products so I could have more buttons than what was available on my old keyboard and mouse, and if they're just going to duplicate A, or 1-6, they're not really helping me.

 

How do I unassign the DPI changing buttons and profiles? I'd like to be able to use these mouse buttons for other things.

 

The ICUE software also seems not even remotely intuitive, and buggy. I figured out how to change the LED colors on the mouse and can watch them change in real time when I do so (but they don't save) -- and doing the same thing trying to change the keyboard colors produces absolutely no change at all. It just stays the default color.

Link to comment
Share on other sites

What version of iCUE are you running? There was a rather large "Actions bug" on iCUE 3.22 and 3.23. Your symptoms appear to be similar, but should not be in place on the last two versions. I do have both products and haven't seen this on the recent versions.
Link to comment
Share on other sites

 Share

×
×
  • Create New...