Jump to content
Corsair Community

no sidetone on corsair virtuoso


Recommended Posts

I purchased a Virtuoso headset about a week ago and the sidetone never worked. I deleted all the drivers and redownloaded. That didnt work. I deleted icue and that didnt work either. I spoke with customer support and they said I should warranty it out. I did that and the sidetone doesnt work on this pair either. I'm pretty sure this is a software issue. Would really appreciate any help I can get with this! Thank you!
Link to comment
Share on other sites

  • 2 months later...
dude, I have the corsair Virtuoso as well and mine won't start when the program does! i have to make it work by using a recorder to force it on. im about ready to find a program with a better sidetone as this is annoying! i expected better from corsair but we ware wrong. the software is subpar and needs a full redo they need to see how razer synapse 2.0 works so they can fix this. :mad::mad:
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

I made an account just to post this in case anyone else came looking for help like I did.

 

You have to hold the mute button at the base of the mic (with mic on) for about 1 sec to activate the side tone. The voice will tell you "Mic feedback on/off" when it triggers.

  • Confused 1
Link to comment
Share on other sites

  • 3 weeks later...

I'm not sure if this will work for every headset but I have the metal edition virtuoso rgb se headset. So I want to first start off by saying that these are great headsets and if you have them please don't give up on them. So as you know the sidetone works for the pc but then shuts off after plugging them into the ps4. What I did was buy the ST100 rgb stand and connected the stand to my ps4 then connected the usb for the headset to the side (not the top) of the stand and now my sidetone works. Its a weird fix but a fix nonetheless.

Snapchat-678338820.thumb.jpg.57000121a1c0aa8becc299cb1b37eba5.jpg

Link to comment
Share on other sites

  • 5 months later...

I got an issue that in wireless mode I cannot disable the sidetone. In wired mode it works okay and i can adjust the sidetone in ICue.

 

Found a solution that worked for me.

https://www.poly.com/us/en/support/knowledge-base/kb-article-page?lang=en_US&urlName=Computer-Headsets-How-to-Enable-Disable-Sidetone-in-Windows-7-Vista

Quote

 

To enable sidetone:

  1. Open the Sound window by clicking Start > Control Panel > Hardware and Sound > Sound (instructions vary depending on your Control Panel view).
  2. Click the Recording tab.
  3. Click the headset you would like to test, and then click the Properties button. The Transmit Properties window appears.
  4. Check the Listen to this device box.
  5. Click Apply.

 

To disable sidetone:

  1. Open the Sound window by clicking Start > Control Panel > Hardware and Sound > Sound (instructions vary depending on your Control Panel view).
  2. Click the Recording tab.
  3. Click the headset you would like to test, and then click the Properties button. The Transmit Properties window appears.
  4. Clear the Listen to this device checkbox.
  5. Click Apply.
  6. Click OK.
  7. Click OK to close the Sound window.

 

 

Link to comment
Share on other sites

  • 3 months later...
You have to hold the mute button at the base of the mic (with mic on) for about 1 sec to activate the side tone. The voice will tell you "Mic feedback on/off" when it triggers.

 

This. Thank you. I've owned my Virtuoso for a few months, and sidetone always worked perfectly until this morning. The slider was grey and uninteractable in iCUE. Holding the mute button reactivated it.

Link to comment
Share on other sites

  • 4 weeks later...

Edit - I realize this is an old thread but I feel its relevant to the original post.

 

My sidetone stopped working in wireless mode after the most recent iCue software update. It works in USB mode. I've tried all sorts of things. Restarting windows, disabling and re-enabling sidetone many times, nothing has worked. I really love this headset and find this feature extremely useful.

 

iCue version is: 4.12.214

Dongle Firmware: 0.16.80

Virtuoso SE: 0.017.149

 

I've checked for updates on all 3 of these and none of them come back saying update available.

 

-------

After further troubleshooting - I tried a repair, it didn't fix the sidetone issue. Tried uninstalled and reinstalling the current version and then tried installing the old version(4.11.274) - No resolution. I did get it work however when I did a system restore which included the old version mentioned previously. I have no idea what changed with the new update but it definitely seem to have broke how sidetone works wirelessly.

Link to comment
Share on other sites

  • Corsair Employees
Edit - I realize this is an old thread but I feel its relevant to the original post.

 

My sidetone stopped working in wireless mode after the most recent iCue software update. It works in USB mode. I've tried all sorts of things. Restarting windows, disabling and re-enabling sidetone many times, nothing has worked. I really love this headset and find this feature extremely useful.

 

iCue version is: 4.12.214

Dongle Firmware: 0.16.80

Virtuoso SE: 0.017.149

 

I've checked for updates on all 3 of these and none of them come back saying update available.

 

-------

After further troubleshooting - I tried a repair, it didn't fix the sidetone issue. Tried uninstalled and reinstalling the current version and then tried installing the old version(4.11.274) - No resolution. I did get it work however when I did a system restore which included the old version mentioned previously. I have no idea what changed with the new update but it definitely seem to have broke how sidetone works wirelessly.

 

I would try creating a new profile in iCUE to see if the sidetone is any different. A clean install of iCUE may also help. If you decide to do a clean install, I would export your saved profile(s) before doing so.

Link to comment
Share on other sites

  • 2 months later...

Hi, i got myself a new HS45 SURROUND  headset and nor the sidetone or the mic levels are showing up but i can still hear my self, i've looked in the sound control panel and it says that the "listen to this device" is off. Please help.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...