Jump to content
Corsair Community

Cant get microphone to function


Yobo1987
 Share

Recommended Posts

Hi, i bought a Void Pro RGB Wireless headset yesterday.

Everything except the microphone if working.

 

As soon as i turn on the headset the voice says "microphone off" and a red led light is showing on the mic.

I have read that i might be a compatibility issue with Windows 10.

Since yesterday afternoon i have looked trough this forum, Corsairs support page and a countless number of other pages for a fix.

So far it dosen´t seem like Corsair have any intention of fixing this or acknowledge that its a big issue.

They give some sporadic tips on how one might be able to solve it.

I have tried everything i can in order to get the microphone to work.

Looked at my privacy settings, setting it as default, reinstalling the iCUE software, tried with the software on and off, Updating the headset, pairing it again and a lot more so called fixes with no result.

 

So i am at the roads end here.

Either i get it working today, or i return this for another working product from a different company.

I have never used a Corsair headset before.

But if it this kind of quality, with almost no support or any official patch to fix this, i will never use a Corsair headset again.

I mean come on Windows 10 has been the most used system for years now.

If they have known about the problem for this long and still have not come up with an official fix, they are not interested in fixing it now either.

Edited by Yobo1987
Link to comment
Share on other sites

 Share

×
×
  • Create New...