Jump to content
Corsair Community

ryanrf15
 Share

Recommended Posts

Hey guys,

 

I recently got a hx750i as part of an auction bundle. The PSU seems lightly used and I was planning to switch it out with my current one. After running some load tests I noticed a problem.

 

When I try to run the fan through link/icue the system shuts down immediately. And keeps restarting at windows login till I remove the link cable. When I press the fan test button it twitches a bit but nothing else happens. And digging further I found that corsair does not support second hand warranty (which is not what I expected). So I'm left with trying to fix it myself.

 

Just wanted to ask if anyone has come across this problem. My plan would be to take the fan out and test it separately. Hopefully its the culprit and I can just install a custom one. Any diagnostics after that is beyond me.

 

Side note, I maxed out my CPU and GPU with stress tests and the psu only clocked around 350W. I'm running a 8700k and 1080 TI (not overclocked). Hardware is a lot more efficient than I remember.

 

TLDR: HX750i problem - system shuts down on fan spin - no warranty - how to fix - help :[pouts:

Link to comment
Share on other sites

  • Corsair Employees
Unfortunately this is not something we can assist you with here as opening up and attempting to repair a PSU can result in serious bodily harm and/or death as the capacitors have the capability to hold a large amount of voltage for years after they have been unplugged from the wall.
Link to comment
Share on other sites

 Share

×
×
  • Create New...