Jump to content
Corsair Community

Mouse lag when I open iCUE


charbel1011
 Share

Recommended Posts

Hey, hey!

 

Few suggestions.

 

- Update any mouse firmware.

- Try disabling Threaded Optimization in NVidia Panel if you have an NVidia GPU.

- Create a rule for G-Sync if you have G-Sync monitor to only run when in full screen and not when in windows mode.

- Check the iCUE profile has not dropped the mouse DPI to a low number if you have a Corsair mouse. Happens when you import DPI settings on community profiles some times - annoying DPI changes.

Link to comment
Share on other sites

Hey, hey!

 

Few suggestions.

 

- Update any mouse firmware.

- Try disabling Threaded Optimization in NVidia Panel if you have an NVidia GPU.

- Create a rule for G-Sync if you have G-Sync monitor to only run when in full screen and not when in windows mode.

- Check the iCUE profile has not dropped the mouse DPI to a low number if you have a Corsair mouse. Happens when you import DPI settings on community profiles some times - annoying DPI changes.

 

I actually fixed it. by uninstall my logitech gaming software and installing logitech g hub the new one. that fixed it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...