Jump to content
Corsair Community

SP120 RGB Pro - RGB LED not lighting up but fan spins


k3u
 Share

Recommended Posts

Hello everyone,

 

I did a lot of research but couldn't find my answer on Google so here I am.

 

I just finished building my new Lian-Li O11 Dynamic rig and of course I bought as much RGB fans as possible to showcase the build. I just picked up 6x SP120 RGB Pro and installed them today. The 3-pin fans work fine (currently plugged directly into 4-pin headers on the motherboard, I'm ordering a fan splitter to power the remaining 3 fans), the RGB 4-pin are plugged into the Lighting Node Core that comes included in each 3-pack fan kit. That is powered by a SATA cable (the same SATA cable that's also powering my SSD & HHD if that matters) and the other end plugs into a USB 2.0 header. The fans are plugged in sequential order 1>2>3>4>5>6.

 

Here's the weird part, the fans do not light up. I updated iCUE to the latest firmware today, sometimes it would light up, but 95% it wouldn't, I was messing around with the settings and sometimes when I set my fans to "SP120 RGB (non pro series)", it would light up but I wouldn't be able to control the lighting at all. Then a restart and it's all gone, back to square one. I'm super frustrated, am I missing a component to power these lights? I even checked my power supply cable, switched 2.0 header ports, even swapped out the Lighting Node Core to see if that was defective. Nothing is working, please someone shed some light on this.

 

My specs:

R7 3800X

Gigabyte X570 Aorus Master

G.Skill 32GB TridentZ 3600MHz @ 16CL

Sapphire Nitro+ 5700XT

Seasonic Gold Prime 850W PSU

DeepCool Castle 360EX AIO

Lian Li O11-Dynamic

 

EDIT 1: So I got all the lighting to work on the fans. I just unplugged all and restarted and went one by one. In iCUE my fans only work when its set to SP RGB SERIES Fan even though mine are SP RGB Pro Series. Whatever, but the weird pard is that the LEDs are all wonky, all fans are flashing difference colors when I use Rainbow shift but one fan. The one fan does it correctly, the rest are not correctly colored unless I put them all to white LED. Even certain static colors don't match, for example I tried yellow and 3 of the 6 fans are yellow, the rest are magenta and other random colors.

 

https://imgur.com/a/WD3Z469

 

EDIT 2: I swapped out USB headers, did not work. I swapped out lighting node core, did not work. I did test each fan individually and when they're plugged into port 1, every effect works normally. Any fan plugged from Port 2-6, they all flash/flicker so I know it's not a fan or LED issue. So fan#1 plugged into port#1 works fine. Fan #2 plugged into port #2 flickers. But if I switch the ports from Fan #1 to port #2 and vice versa. Fan #1 would flicker and Fan#2 would work flawlessly. And its not a lighting core issue because I did the same with a brand new lighting node core, same symptoms. But what's the cause of this? I even tried to plug the lighting hub core into a separate SATA cable for the PSU. Still didn't resolve the flickering when I set a pattern.

Edited by k3u
Link to comment
Share on other sites

I'm having a similar issue which I've posted about. But mine is concerning the rad fans on my Corsair H100i AIO. My case fans are 3ea. LL120mm and the node has no problem with them. But iCUE will not detect either the ML120mm fans of the cooler or even the cooler itself. Frustrating for sure, as I've spend hundreds of dollars on these Corsair products only to see that they are having trouble communicating with one another.
Link to comment
Share on other sites

 Share

×
×
  • Create New...