Jump to content
Corsair Community

K95 Volume Wheel Not Working


lerodemmy
 Share

Recommended Posts

I have both a K95 RGB and a K95 RGB Platinum connected to my PC. I've had them both for a long time and all of sudden, out of nowhere, the volume wheels and mute buttons do nothing. I have the latest firmware and iCUE versions.

 

Please help!

Link to comment
Share on other sites

Bottom right of the windows 10 toolbar is the sound icon.

Right click and go 'sound settings'.

The 'choose output device' should be a wdm audio device for your multimedia keys to work. (I'm like 90% sure of this).

Select different audio devices to see if it brings your wheel and mute back.

If not, it's probably the keyboard/software. There is a bug going around with the new update that you might need to wait for the next update.

Link to comment
Share on other sites

  • 7 months later...

Captain here.

 

After trying about 5 ways to fix this the easiest remedy was the most effective.

 

Unplug keyboard from computer via usb ports

Hold the ESC on your keyboard

While maintaining holding down the ESC key plug the keyboard back in

Wait ~10 seconds and then release ESC the keyboard should perform a reset

 

ICUE now recognizes the keyboard and the volume rocker is now working

 

**flies away**

Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...
My mute button and volume wheel aren't working on my K95. Media keys work fine. I've tried updating iCUE and firmware, reinstalling iCUE, unplugging and replugging the keyboard, restarting my computer, the unplug+ESC reset, and the F1+Lock reset. No ASIO driver. Looks like this issue has plagued Corsair keyboard for almost a decade, but a guy can hope for a fix. :) I would love if I am missing something simple. Help!
Link to comment
Share on other sites

  • Corsair Employees
My mute button and volume wheel aren't working on my K95. Media keys work fine. I've tried updating iCUE and firmware, reinstalling iCUE, unplugging and replugging the keyboard, restarting my computer, the unplug+ESC reset, and the F1+Lock reset. No ASIO driver. Looks like this issue has plagued Corsair keyboard for almost a decade, but a guy can hope for a fix. :) I would love if I am missing something simple. Help!

 

Hi mellowmaniacal,

 

I suggest contacting our support team by opening a ticket at https://help.corsair.com, they'll be able to help you further troubleshoot.

Link to comment
Share on other sites

 Share

×
×
  • Create New...