Jump to content
Corsair Community

Corsair Strafe powering up but not typing


Recommended Posts

I recently just got this and when i plug in the keyboard, i get the red lights, but i cannot type on it at all


I have installed the Corsair Utility Engine and that was not detecting it. I tried installing the latest version of iCue with no change


When i go to device manager and check the keyboard section i can see 2 HID Keyboard Devices which when you check the properties it says that its location is Corsair Virtual Input device. Trying to update the driver from Device manager says that it is using the best drivers currently available.


I have tried all my USB ports and it is the exact same. I have tried holding ESC when plugging in, tried holding down the FN and F1 keys and get no change. I have tried plugging in just the USB with the Keyboard marker and the other cable solo and no change.


I've updated my chipset drivers also and no change, haven't updated the BIOS yet, but i dont think that should resolve this, but will try after i get back from work. Really not sure what i have missed here

Link to comment
Share on other sites

Update: Got contacted from Corsair and advised to try and hard reset by unplugging it and using a PIN on the rest button under the leg stand. This has not helped me solve my issue, but might help someone else.



1. Unplug your keyboard from your computer.

2. Use the paperclip or pushpin to push the reset button within a pinhole on your keyboard.

3. For some keyboards, the reset button will be located near the polling rate switch next to the cable. On others, it will be located underneath one of the tilt legs on the bottom of the keyboard.

4. While pushing the reset button, plug your keyboard back into the computer. This should cause your computer to recognize a new drive called “CRP_Disabled.”

5. Open “CRP_Disabled” and delete the file titled FIRMWARE.BIN.

6. Copy the firmware file you downloaded from us into CRP_Disabled (The file name should contain “ISP”).

7. Unplug your keyboard, then plug it back in.

Link to comment
Share on other sites

  • Create New...