Jump to content
Corsair Community

K70 Rapidfire Mk.2 SE (White) - number row keys stop working randomly


formVfunction
 Share

Recommended Posts

I'm having a weird issue where my number row keys stop working at totally random intervals. No correlating software/firmware updates or hardware changes when it started. Just using it one minute, next minute the keyboard was having weird input issues. Nothing I do fixes it (un/re-plug KB, hard reset, restart Corsair service, toggle/reinstall KB in device mgr, clean iCUE install, tried everything but clean OS install. Have most recent BIOS, updated chipset drivers, updated iCUE, Windows. Just comes and goes on it's own, takes 15-20 minutes to go away.

 

At first it was the F keys, and instead of doing nothing they were executing random shortcuts, sometimes retaining normal function as well. Example: Alt+F4/F4/F5 were launching chrome (+og func), F1 & F3 were opening File Explorer, F2 taking screenshots, etc. Happened that way for awhile and then went to number row (probably after my 2nd or 3rd clean install/profile wipe).

 

I still get the USBxp driver disabling itself sometimes, but not as much as before updating the chipset drivers, and it doesn't happen at the same time as the keyboard. But that's for the H115i anyway, and is something OS-side from what I understand.

 

The only other minor issue I'm having is the Void Playback Visualizer seemed to start having issues around the same time. Worked flawlessly for 1-2 years, now it only works for a few minutes before getting frozen mid-beat. KB input and iCUE still work, the KB LED's just get stuck as if the song is holding that note, sometimes resumes after a bit, sometimes doesn't.

 

After the input issues had been going on for a couple of weeks already, I took advantage of the holiday sales and added a Node Pro + 4 strips to my iCUE suite. That's the only change I can think of that might correlate with the Void Visualizer. Already had the K70SE white, M65 RGB white, MM800 mousepad, Void Pro white, H115i 280mm, and 2 HD140mm fans. The Node Pro also enabled iCUE control for the HD140's (so much better than the button controller).

 

If I were to make an assumption, I would lean toward the OS being responsible for the KB input issues because I haven't seen any Corsair users with the same problem. I haven't done a clean OS install for about a year and have been getting the itch.

So that will probably happen soon in any case, and maybe that will fix it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...