Jump to content
Corsair Community

Keys pressing on there own


vk19
 Share

Recommended Posts

hey!

i bought k70 about 2 months ago and last 2 weeks keyboard is going crazy and pressing keys itself

 

1. soft and hard reset didn't worked

2. moving the BIOS switch to BIOS mode too

3. firmware is 3.08

and i cant send it back cause im not in US now

 

the only think that helped for a short time is unplugged and plugged usb from pc

 

please help me with this, any advice or something that can help me

 

some guy had a post like this in 2016, so i will upload a GIF he did, cause i have the same problem

 

UPDATED: i tried to connect it with my laptop, where is no any soft from corsair or something like that and again, keyboard was gonna crazy, pressing keys

 

http://i.gyazo.com/b3f91a6cc18678c75407d58abdc6a65d.gif

Edited by vk19
Link to comment
Share on other sites

Two things to try:

 

1) Clear out your Actions Library. You can leave assigned actions in the profile alone. Only delete the Library. This is a known bug in 3.22 and 3.23. You have not listed your iCUE version, but the timing matches and the behavior can be very erratic.

 

2) If that does not work (or you have very elaborate macros), you might need to roll back to iCUE 3.21 before this issue was introduced. Be aware, profiles are not backwards compatible and you will need to delete your user settings when doing this. If you don't have all your profiles backed up, this is a permanent consequence and still a lot of work to set-up again even if you do. I don't recommend rolling back unless you are really prepared to start over.

 

It is also possible it is neither of these and you have a genuine hardware level issue. However, the above bug accounts for about 90% of the problems the last 6 weeks, so it is the place to start.

Link to comment
Share on other sites

I have the exact same issue since updating - I press my ESC key and all my F1 to F5 keys start doing EEEEE RRR QQQQ RRREEE and my ESC does ffffffffff when pressed. However, the keys when pressed will continue to do the random keys as if the key was stuck down.*

 

 

I have to turn macros on and off again to make it work once more. Any advice would be appreciated.

 

I am running firmware 3.08 for the k95 RGB and iCUE was just updated (I suspect this is the cause as firmware has been 3.08 for some time) to 3.23.66.

 

Incredibly frustrating - It appears to toggle too; pressing ESC once turns this weird crap functionality on, then pressing once more or pressing one of the G* keys with a macro then turns it off again.

 

Advice would be appreciated - :)

Link to comment
Share on other sites

Two things to try:

 

1) Clear out your Actions Library. You can leave assigned actions in the profile alone. Only delete the Library. This is a known bug in 3.22 and 3.23. You have not listed your iCUE version, but the timing matches and the behavior can be very erratic.

 

2) If that does not work (or you have very elaborate macros), you might need to roll back to iCUE 3.21 before this issue was introduced. Be aware, profiles are not backwards compatible and you will need to delete your user settings when doing this. If you don't have all your profiles backed up, this is a permanent consequence and still a lot of work to set-up again even if you do. I don't recommend rolling back unless you are really prepared to start over.

 

It is also possible it is neither of these and you have a genuine hardware level issue. However, the above bug accounts for about 90% of the problems the last 6 weeks, so it is the place to start.

 

Should have read your response... Clearing my action library has fixed the bug. Any news on when an update/fix is coming>?

Link to comment
Share on other sites

Two things to try:

 

1) Clear out your Actions Library. You can leave assigned actions in the profile alone. Only delete the Library. This is a known bug in 3.22 and 3.23. You have not listed your iCUE version, but the timing matches and the behavior can be very erratic.

 

2) If that does not work (or you have very elaborate macros), you might need to roll back to iCUE 3.21 before this issue was introduced. Be aware, profiles are not backwards compatible and you will need to delete your user settings when doing this. If you don't have all your profiles backed up, this is a permanent consequence and still a lot of work to set-up again even if you do. I don't recommend rolling back unless you are really prepared to start over.

 

It is also possible it is neither of these and you have a genuine hardware level issue. However, the above bug accounts for about 90% of the problems the last 6 weeks, so it is the place to start.

 

thanks for your answer

i tried what you advice but nothing works for me

1. i never add something in actions library or maybe i don't understand what u mean, saying DELETE ACTIONS LIBRARY, explain me please, cause when i look there its empty

 

2. i delete my cue_from everywhere, like appdata or localappdata) and install 3.21 but it doesn't. My first cue version was 3.23, then, when problem begins, i uninstall it and put 2.24 version and it works fine like two days, but then problem begins again. i forget to say that one time, when keyboard was going crazy, i could hardly turn cue off(cause all keyboards was pressing together), but it still continue going crazy.

 

i don't know why but i think the problem is from firmware version, when i wrote to corsair service, they send me 3.08, but i thought that it was gonna be a little earlier version. What you think about that?

Edited by vk19
Link to comment
Share on other sites

I have the exact same issue since updating - I press my ESC key and all my F1 to F5 keys start doing EEEEE RRR QQQQ RRREEE and my ESC does ffffffffff when pressed. However, the keys when pressed will continue to do the random keys as if the key was stuck down.*

 

 

I have to turn macros on and off again to make it work once more. Any advice would be appreciated.

 

I am running firmware 3.08 for the k95 RGB and iCUE was just updated (I suspect this is the cause as firmware has been 3.08 for some time) to 3.23.66.

 

Incredibly frustrating - It appears to toggle too; pressing ESC once turns this weird crap functionality on, then pressing once more or pressing one of the G* keys with a macro then turns it off again.

 

Advice would be appreciated - :)

 

i think we have different problems, mine is going real crazy after 15 minute i turn my PC on, like opening, zooming and trying delete everything on desktop :[pouts:

Link to comment
Share on other sites

OK, then unfortunately I think we are looking at a different problem. That was a possibility and this is more extreme than most people see on the bug in discussion. If you went back to iCUE 3.21 or even CUE 2 (2.24) and it still does this, it's not the same issue.

 

Support is going to give you a firmware file to flash the board. I don't know what else can be done. If it does not work, they will replace the keyboard. Go ahead and upload the purchase invoice to your ticket if you haven't already. That is required for the RMA replacement. You are going to want to minimize the amount of back and forth conversation. Make sure you complain a little in your dialogue that the keyboard is only two months old. Don't assume they will get that by looking at the purchase invoice.

Link to comment
Share on other sites

OK, then unfortunately I think we are looking at a different problem. That was a possibility and this is more extreme than most people see on the bug in discussion. If you went back to iCUE 3.21 or even CUE 2 (2.24) and it still does this, it's not the same issue.

 

Support is going to give you a firmware file to flash the board. I don't know what else can be done. If it does not work, they will replace the keyboard. Go ahead and upload the purchase invoice to your ticket if you haven't already. That is required for the RMA replacement. You are going to want to minimize the amount of back and forth conversation. Make sure you complain a little in your dialogue that the keyboard is only two months old. Don't assume they will get that by looking at the purchase invoice.

 

unfortunately i cant return it cause i'm not in US now, but anyway, thank you man for your help

Link to comment
Share on other sites

today i tried again to connect keyboard with my laptop, where is no any soft from corsair or something like that and again same problem, like on my PC

i even opened it and disconnect some cable like some guy advice to do in youtube, but nothing works for me

 

Any advice, what can it be??

Maybe this keyboards have some USB cable problem and replacing it can solve this problem?

Edited by vk19
Link to comment
Share on other sites

 Share

×
×
  • Create New...