Jump to content
Corsair Community

M65 Pro RGB side button issues.


SatyenB
 Share

Recommended Posts

Sorry to make this my first post.

 

I know this is an old mouse, but it is still being sold here in India with warranty.

Contacted the Corsair India support and they asked me to create an RMA.

 

iCue v3.23.66

 

The back and forward buttons stop working randomly. Only upon repairing the iCue installation at least twice, do they start working. Upon reboot, back to buttons not working.

 

However this issue is with the iCue software and not the mouse.

How did I figure this?

Upon exiting the software, the buttons work perfectly.

Launch iCue and the problem is back.

 

As mentioned earlier below, this problem persists since long.

M65 Pro RGB Side buttons stop working

Link to comment
Share on other sites

Normally, dysfunction across the mouse forward/back buttons is an installation issue. However, be aware iCUE 3.22 and 3.23 have a bug affecting programmable mice and keyboards that can cause unexpected key/button behavior. If you have anything in your Actions Library (mouse or keyboard), delete those. You can leave the actual assigned actions in the main profile. The bug is related to the Library.
Link to comment
Share on other sites

That's why I was wondering about the "transference bug" (don't have a better name) that affects keyboards and mice in 3.22 and 3.23. It causes keys/buttons to send their function to another key. F4 creates a ~, macros fail because of this, and just general weird behavior with the mice. Don't delete your profiles or anything else rash. There are a ton of threads talking about this from multiple angles. Start by clearing out your Actions Library -- just the Library. You can leave all the assigned actions (keyboard and mouse) alone. If that does not clear this up, then we may be looking at a different kind of problem.
Link to comment
Share on other sites

 Share

×
×
  • Create New...