Jump to content
Corsair Community

K95 and ICUE new keybard 12-18-19


Kitaro
 Share

Recommended Posts

Hey All,

 

I hope this helps someone. Like a lot of you I also had many problem getting the keyboard to work.

1) Pressing F1 key caused random keys to trigger

2) On start up there are 1 to 3 error messages that started with " There is an error detected with your device...…."

2a) On start up my other devices would act up no lights random functions Headphones and RAM

3) Pressing escape also caused random key strikes (this is important as due to this I could not do a soft reset of the keyboard memory. did not know this for 3 days of trouble shooting

4) Macros were doing the strangest things (random keys, lockup etc....) To much to go into but lets says macros where not working

** I think what fixed this was deleting everything from action library.

5) System power on the keyboard would come up in unknown states.

 

I tried a bunch of stuff on these forums with no success. Finally stumbled across what seems to have fixed the problems.

 

Initially not sure what was wrong as the keyboard did not work from the initial plug in.

 

1) The profile error message. At some point I must have deleted the onboard HW Profiles which there are three of. K95P HW1, K95P HW2, K95P HW3

** If you have done this random errors and functionality may occur at start up.

2) I thought I was doing a soft reset of the keyboard but since the escape key had random outputs I was not.

3) Once the escape key started working I was able to do a soft reset of the keyboard which reactivated the build in HW Profiles. It took three computer reboots for the keyboard memory and sw to sync up.

4) DO NOT PUT! anything in action library. anything in there seems to generate random functionality and errors

5) Macros in general seem a bit tweaky. I had to forgo complex macros i.e ones with multiple delays and keystrokes to simple 1 or 2 actions. This sucks but fortunately I do not need more that this at the moment. Eye Candy, and the G-keys for now.

6) I installed/uninstalled and reinstated s/w multiple times. What I did here was followed the instructions on the wedsite that has you go into the registry and delete a few registry items.

** I tried the build in uninstaller and that did not work

** I tried REVO Uninstaller and that rooted out more items

** Lastly followed the web site instructions and found the 2x registry entries which I then manually removed.

** This helped, not sure

 

To be honest I just flailed around for several days to get to this point.

 

EDIT: Day 2 and everything is working (K95, Headphones and RAM) No errors on startup and no random key outputs. Will try more complex macros over the next couple of days.

 

EDIT: Several Days Later --> On system power on for the day the keyboard would either come up in an unknown state or I would get a "no devices detected" error. Yes no devices were detected verified in icue. This is the K95 Keyboard, RGB RAM and Headphones.

 

** What I found was since my computer is setup to accept a password on power up. What I have to do is wait till all background services are completed loading. On my PC this is about 90 seconds. Found this time by trial and error since I cannot tell when the services are actually done loading. The PC boots to the Windows 10 password screen in about 6 seconds so I have to be patients and wait a bit before entering the password.

 

https://i.imgur.com/uYHRunD.jpg

https://i.imgur.com/MelSVUO.jpg

Edited by Kitaro
changed pics to links
Link to comment
Share on other sites

 Share

×
×
  • Create New...