Jump to content
Corsair Community

RMx Series RM550x: Broken or not enough power?


C-X
 Share

Recommended Posts

Hi!

 

I'm building a new PC with an RMx Series RM550x power supply.

 

If I don't plug in the cables for the CPU and GPU the pc kinda starts, at least all the fans and LEDs are on. But when i connect all the cables i can hear a "click" when I press the power button but nothing happens.

 

The PC started one time with alle the cables plugged in, but went off again shorty after I put two connector for the keyboard and the mouse in the usb port.

 

My Components are:

- MSI MPG X570 Gaming Edge WIFI

- AMD Ryzen 7 3800X

- Zotac Gaming GeForce RTX 2070 SUPER AMP Extreme 8GB GDDR6

 

Is my power supply broken or does it not have enough power?

Link to comment
Share on other sites

My guess here........not enough power. If I were you, I'd get an 850W just to be on the safe side and I think nVidia site states that for a 2070S you'd need a 650W PSU.

I use 500-550W PSU when I building a super budget PC, with a video card that usually won't require the 8pin connector and it's either a Quad-Core or Dual-Core system.

Edited by Nazgul
Link to comment
Share on other sites

I changed the PSU to 650W, but it's still the same. As long as the CPU is connected to the PSU the System won't start. Even if I disconnect the GPU. I can't imagine that the CPU alone needs more the 650W. Any idea what might be the problem?
Link to comment
Share on other sites

I changed the PSU to 650W, but it's still the same. As long as the CPU is connected to the PSU the System won't start. Even if I disconnect the GPU. I can't imagine that the CPU alone needs more the 650W. Any idea what might be the problem?

 

You might be improperly using a PCIe cable instead of the EPS12V cable for the CPU power.

Link to comment
Share on other sites

 Share

×
×
  • Create New...