Jump to content
Corsair Community

iCue + Corsair scimitar pro RBG + world of warcraft = problems


NessIsAMess
 Share

Recommended Posts

I've had this same problem ever since I bought my first corsair Scimitar Pro RBG over a year ago, where the side buttons sometimes don't work in World of Warcraft at all. After a bit of googling, it seems the issue is rather common and none of the suggested "fixes" has worked for me.

 

Some days the mouse works just fine, and other days I have to restart my computer several times before the side buttons start working in wow. Closing down Wow, Battle.net and iCue from the task manager and then reopening them again (starting fron iCue) doesn't help. Only shutting down and restarting the computer works for some reason.

 

Today I noticed that even after several restarts the mouse just didn't want to work in game, but when I restarted one more time and waited on the windows login screen for my mouse to stop switching colours and settle for my chosen profile lighting, it worked normally again. I'm starting to think the issue is somehow tied to Windows 10 loading something and/or internet connection loading and somehow causing issues with iCue. :sigh!:

 

I know some other mice have their software tied to an online profile, and if there's no internet connection they sometimes don't load up their profiles because of that. Does iCue have a similar thing? And is there a way to force it to always work in offline mode by changing the code?

Link to comment
Share on other sites

I know some other mice have their software tied to an online profile, and if there's no internet connection they sometimes don't load up their profiles because of that. Does iCue have a similar thing? And is there a way to force it to always work in offline mode by changing the code?

 

Corsair profiles don't work this way, so that is not the issue. If it has been going on for a year, I am not sure of the underlying cause. However, one thing to be aware of is a bug in iCUE 3.22 and 3.23 that causes Actions saved to your Library to transfer themselves to other locations. If you have anything in the Library, delete those while leaving the assigned profile actions alone. See if that returns functionality. This applies to both keyboards and programmable mice.

Link to comment
Share on other sites

 Share

×
×
  • Create New...