Jump to content
Corsair Community

Corsair 570x Fan's RGB not working


Swagata
 Share

Recommended Posts

I recently bought an corsair 570x. The front 3 fans are running but rgb not working. Yes, I did plugged in the rgb hub sata power. I am thinking something is defective like the fans led or or the hub or rgb controller. How can I determine that ? Or Am I missing something ?
Link to comment
Share on other sites

Do you have the fan hub connected to the push button controller?

Are the fans connected to the fan hub in positions 1-2-3?

 

yes, the fan hub is connectedto sp lighting controller which is also connected to case push button. yes fans r connected as 1 2 3. can i connect one fan's rgb cable to motherboard just to see if the rgb works ?

Link to comment
Share on other sites

No, don't connect it to the motherboard. Four pin motherboard RGB is 12V. Those are 5V. Connecting it to the motherboard will (not may, will) damage the LEDs.

 

Start with putting different fans in port 1. Once one works, put the next one in to port 2. The fans are daisy chained so one bad fan can take the whole chain out.

Link to comment
Share on other sites

No, don't connect it to the motherboard. Four pin motherboard RGB is 12V. Those are 5V. Connecting it to the motherboard will (not may, will) damage the LEDs.

 

Start with putting different fans in port 1. Once one works, put the next one in to port 2. The fans are daisy chained so one bad fan can take the whole chain out.

 

tried three fan in port 1 seperately. none works. these means all the fans led or hub is defective right ?

Link to comment
Share on other sites

Or it could be the push-button controller is defective.

Did you push any buttons on it? Wondering if maybe it's set to "off". The push-button controller should be connected to the end of the RGB Fan LED Hub.

 

yes i tried pushing that and case push button as well. pressing multiple times, press and hold. just nothing. the shop i bought it from doesnnt provide warranty. so i guess i am screwed. but anyway to determine what is actually defective ?

Link to comment
Share on other sites

Not sure what version 570x you have as I don't believe they are all the same wiring connection wise (I could be wrong) but, did you trace the wiring back from the button controller? I know initially on my mirror black version, there is a small (i think 3 bundle) wire connector that was installed right up top of the case under the frame and was very easy to disconnect one or all wires. Note; this connector might only be on the case variants with the light up PSU shroud and front logo.
Link to comment
Share on other sites

yes i tried pushing that and case push button as well. pressing multiple times, press and hold. just nothing. the shop i bought it from doesnnt provide warranty. so i guess i am screwed. but anyway to determine what is actually defective ?

 

At this point ... not really. You might want to check out Johnny_B500's suggestion and trace the wires. Third party shops are notorious for wiring stuff up incorrectly, unfortunately. (It's not uncommon that we see it here.)

 

And you can contact Corsair Support to see if they can help you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...