Jump to content
Corsair Community

Led dying only after 4 months


IJuanTM
 Share

Recommended Posts

Hi there,

 

I've been using the K70 v2 with Red switches for the past 4 months and am absolutely loving the keyboard. The problem tho started last week.

 

I was just busy with some school work when I noticed my shift key led was way dimmer that others. I tried looking on help forums and on corsairs site for help and the only things I found were, "reset your pc, it should be fixed" and "reinstall the ICue software". Both of these things I did but they didn't fix the problem.

 

So thats why I came here, hopefully someone can help me.

 

- Thanks, IJuanTM

Link to comment
Share on other sites

Hi there,

 

I've been using the K70 v2 with Red switches for the past 4 months and am absolutely loving the keyboard. The problem tho started last week.

 

I was just busy with some school work when I noticed my shift key led was way dimmer that others. I tried looking on help forums and on corsairs site for help and the only things I found were, "reset your pc, it should be fixed" and "reinstall the ICue software". Both of these things I did but they didn't fix the problem.

 

So thats why I came here, hopefully someone can help me.

 

- Thanks, IJuanTM

Try changing your shift led to solid red, green and blue, so you can figure out if one of the colour died or the whole thing is actually dying. Also have you tried it on another PC or another USB port? Fastest way to find out if its a software fault or hardware fault. If the issue persist across other devices then it is most likely hardware fault, I suggest you RMA it.

Edited by Cruxiaer
Link to comment
Share on other sites

 Share

×
×
  • Create New...