Jump to content
Corsair Community

Problem with SP120 RGB fans


ProfRyan
 Share

Recommended Posts

I bought the Corsair 570x case which comes with 3 SP120 RGB fans and a control node. I also bought the Corsair h115 RBG Platinum pro CPU cooler. Initially i wanted to mount the radiator on the top but found (my own fault for not checking ahead of time) that it will not fit in the top. So i moved the radiator to the front and relocated the 3 SP120 fans, 2 of them on the top and 1 as an exhaust fan in the back. I plugged the RGB cables from the 2 fans connected to my Radiator to nodes 1 and 2. I then plugged the RGB cable from the 2 SP120 fans on top to nodes 3 and 4. Finally i plugged the RGB cable from the back exhaust fan into node 5. I then plugged the 3 SP120 pwr cables into system fan 1, 2, and 3 on my Motherboard. The problem i have when i power on the system to test everything is i get RGB for the 2 fans connected to the radiator but nothing, no lights or anything from the 3 SP120 fans mounted on the top and the one on the back. I have double checked the connections to the RGB controller and they are snug. What am i missing?

1484453772_CorsairController.thumb.jpg.c2c62770c557e74ac42941036b2c4d39.jpg

Fans_Front_h115.thumb.jpg.d9d6989af6053cf8f228a270dc709b8f.jpg

Fans_Top_Back.thumb.jpg.d3b7e824d7b63223af31e3232b4d74df.jpg

Link to comment
Share on other sites

hi buddy.... the issue you have is mixing the 2 different types of rgb fans on the RGB Fan LED Hub.. SP fans can not be mixed with any other of Corsairs RGB Fans...

 

do you still have the RGB Fan LED hub plugged into the cases button controller?

Link to comment
Share on other sites

OK, still a bit confused but i think i am learning. So the SP120 fans are not compatible on the same RGB LED Fan Hub (that came with the Crystal Series 570X case. Its sounds like in order to be able to have RGB fan control for both my SP120 case fans and the ML140 fans that came with my H115i RGB Platnum Pro, i would need to purchase a commander pro and connect via the USB port. Is this correct?

 

So for now, i can remove the RGB LED cables for the 2 ML140 fans from the RGB LED Fan Hub and just have the SP120 RGB pro fans plugged into ports 1, 2, and 3. Do i just leave the ML140 RGB LED cables unplugged for now? Will that impact their performance in anyway outside of no lights?

Link to comment
Share on other sites

 Share

×
×
  • Create New...