Jump to content
Corsair Community

iCue Loses Control of Commander Pro


techfiend
 Share

Recommended Posts

Hello,

 

I have 3 Commander Pros, each with 5 Corsair ML RGB fans. One of the Commander Pros will occasionally disappear from iCue as if iCue has lost the ability to communicate with it. It seems to happen randomly where this one Commander Pro disconnects and reverts to the hardware lighting settings. When this "disconnect" occurs and I go into iCue, the Commander Pro icon associated with the one that disconnects shows but all the fan speeds are frozen and I can't adjust any lighting settings. Restarting iCue service gets rid of icon for the Commander Pro that loses connection and only the two remaining are shown. If I check with USBDeview it shows all three Commander Pros as connected despite this one disappearing from iCue. Been having this problem ever since I started using iCue. Was previously using LINK and never had this issue. The only way I can get iCue to regain control of this Commander Pro is by rebooting the computer or going to device manager and disabling then re-enabling the "USB Composite Device" associated with this Commander Pro. I've tried clean install of iCue and removing all folders and registry entries, no monitoring software like HWInfo is running (persistent driver is NOT enabled), even clean reinstall of Windows. Am using the latest version of iCUE (3.22.74) and Commander Pros are all updated to latest firmware (0.9.212), and this same problem has occurred with all previous versions of iCue and firmware I have used.

 

System specs:

MSI Z390 Godlike

9900k

2 x 2080ti NVLink

Corsair AX1600i

32GB G.Skill Trident Z 4600Mhz

Intel Optane 960p 960GB

Samsung 850 Pro 2TB

WD Black 1TB NVMe

3 x Commander Pros

15 x Corsair ML RGB Fans

Edited by techfiend
Link to comment
Share on other sites

Here is an error log from today. Turned on my computer around 19:59. Didn't get back to my computer for about a half hour, but by the time I started using it the problem had already occurred, I believe right at the beginning 19:59:22.

 

When I finally got back to my computer around 20:30, I disabled/renabled the "USB Composite Device" associated with this Commander Pro in device manager to get it reconnected to iCue. After reconnecting it, the error occurred again at 20:34. If you look at 20:34 time you'll notice a bunch of errors. Anyone have any idea what is causing this?

 

2019-12-06T19:59:22 I cue.init: iCUE version: 3.22.74

2019-12-06T19:59:22 I cue.init: Updates server: https://www3.corsair.com/software/CUE_V3/

2019-12-06T19:59:22 I cue.init: Build type: Public Release

2019-12-06T19:59:22 I cue.init: Applicaiton ID: 6768

2019-12-06T19:59:23 W cue.locale: Cannot find dir for qt *.qm files

2019-12-06T19:59:23 I cue.init.font: Using Regular text font family: "Open Sans"

2019-12-06T19:59:23 I cue.init.font: Using Title text font family: "Gotham Bold"

2019-12-06T19:59:23 I cue.hid_device_detector: Start worker thread.

2019-12-06T19:59:23 I cue.devices.enum.hid: Leaving working state. DeviceEnumeratorBase::WorkingStateChangeReason::UserSessionPropertyChanged Session disallowed.

2019-12-06T19:59:23 I cue.devices.enum.router: Leaving working state. DeviceEnumeratorBase::WorkingStateChangeReason::UserSessionPropertyChanged Session disallowed.

2019-12-06T19:59:23 I cue.devices.enum.clink: Leaving working state.

2019-12-06T19:59:23 I cue.plugin: Trying to load library: "C:/Program Files (x86)/Corsair/CORSAIR iCUE Software/plugins/CUEPlugin.dll"

2019-12-06T19:59:23 I cue.plugin: Library is loading, will check if it's plugin: "CUEPlugin.dll"

2019-12-06T19:59:23 I cue.devices.enum.phost: Leaving working state.

2019-12-06T19:59:23 W cue.plugin: Processing already finished

2019-12-06T19:59:23 I cue.profiles.folders.tree: Profile order deserialization started: "C:\\Users\\\AppData\\Roaming\\Corsair\\CUE/profiles/tree.cueprofileorder"

2019-12-06T19:59:23 I cue.profiles.folders.tree: Profile order deserialization finished: "C:\\Users\\\AppData\\Roaming\\Corsair\\CUE/profiles/tree.cueprofileorder"

2019-12-06T19:59:23 I cue.llaccess: Northbridge: Intel Coffee Lake

2019-12-06T19:59:23 I cue.llaccess: Southbridge: Z390

2019-12-06T19:59:23 I cue.llaccess: Slot count: 4

2019-12-06T19:59:23 W cue.llaccess: "dramWriteByte failed" "[0:5c]" cmd: 37 data: 66

2019-12-06T19:59:23 I cue.actions.macro.win: Init time: 0.429747 (init: 1.5e-06 reset: 0.0200404 )

2019-12-06T19:59:23 W cue.llaccess: "dramWriteByte failed" "[0:5d]" cmd: 37 data: 66

2019-12-06T19:59:23 W cue.llaccess: "dramWriteByte failed" "[0:5e]" cmd: 37 data: 66

2019-12-06T19:59:23 W cue.llaccess: "dramWriteByte failed" "[0:5f]" cmd: 37 data: 66

2019-12-06T19:59:23 I cue.devices.enum.dram: Leaving working state.

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 W QObject::disconnect: Unexpected null parameter

2019-12-06T19:59:23 I cue.session: Locked changed to false

2019-12-06T19:59:23 I cue.session.win: Will notify 'connected changed to' with delay

2019-12-06T19:59:23 I cue.session: Local changed to true

2019-12-06T19:59:24 I cue.hw_profile.manager: Start worker thread.

2019-12-06T19:59:24 I cue.session: Connected changed to true

2019-12-06T19:59:24 I cue.sdk: Entering working state, session connected.

2019-12-06T19:59:24 I cue.sdk.device_watcher: Start prepare RestoreDeviceOrderState

2019-12-06T19:59:24 I cue.sdk.device_watcher: Finish prepare RestoreDeviceOrderState

2019-12-06T19:59:24 I cue.clink.device.hw_lightings: Working state about to change, lock hw lights preview.

2019-12-06T19:59:24 I cue.sdk.automation.server: User session about to be unlocked. Starting a listening

2019-12-06T19:59:24 I cue.sdk.automation.server: Dropping server starting due to disabled SDK

2019-12-06T19:59:24 I cue.devices.enum.hid: Entering working state. DeviceEnumeratorBase::WorkingStateChangeReason::UserSessionPropertyChanged Session allowed.

2019-12-06T19:59:24 W cue.hid_device_detector: Device detector already disabled.

2019-12-06T19:59:24 I cue.devices.enum.router: Entering working state. DeviceEnumeratorBase::WorkingStateChangeReason::UserSessionPropertyChanged Session allowed.

2019-12-06T19:59:24 I cue.devices.enum.clink: Entering working state.

2019-12-06T19:59:24 I cue.devices.enum.phost: Entering working state.

2019-12-06T19:59:24 I cue.plugin: Trying to load library: "C:/Program Files (x86)/Corsair/CORSAIR iCUE Software/plugins/CUEPlugin.dll"

2019-12-06T19:59:24 I cue.plugin: Library is loading, will check if it's plugin: "CUEPlugin.dll"

2019-12-06T19:59:24 I cue.devices.enum.dram: Entering working state.

2019-12-06T19:59:24 I cue.clink.device.hw_lightings: Entering working state, unlock and disable hw lights preview.

2019-12-06T19:59:24 I cue.plugin: Received deviceStatusChanged

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col06#9&252ce42a&0&0005#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col06\\9&252ce42a&0&0005", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col06#9&252ce42a&0&0005#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_01#9&d6957e5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_01\\9&d6957e5&0&0000", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_01#9&d6957e5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=4d8, pid=eed3)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=4d8, pid=eed3) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=4d8, pid=eed3)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=4d8, pid=eed3) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=1038, pid=1290)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=1038, pid=1290) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c232)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c232) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=4d8, pid=eed3)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=4d8, pid=eed3) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=1038, pid=1294)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=1038, pid=1294) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=1038, pid=1294)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=1038, pid=1294) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 I cue.devices: Device vid=1b1c pid=c10 ignored by HidDeviceEnumerator

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c53a)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c53a) not found.

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col01#9&252ce42a&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}\\kbd", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col01\\9&252ce42a&0&0000", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col01#9&252ce42a&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}\\kbd" with delay 0 ms.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c231)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c231) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=4d8, pid=eed3)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=4d8, pid=eed3) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=1462, pid=7b10)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=1462, pid=7b10) not found.

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col06#9&252ce42a&0&0005#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=1038, pid=1290)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=1038, pid=1290) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 I cue.devices: Device vid=1b1c pid=c10 ignored by HidDeviceEnumerator

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col02#9&252ce42a&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col02\\9&252ce42a&0&0001", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col02#9&252ce42a&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_01#9&d6957e5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col03#9&252ce42a&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col03\\9&252ce42a&0&0002", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col03#9&252ce42a&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col04#9&252ce42a&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col04\\9&252ce42a&0&0003", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col04#9&252ce42a&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 C cue.devices.manifest: Cannot find path for manifest key (vid=46d, pid=c539)

2019-12-06T19:59:24 I cue.devices: Manifest for device (vid=46d, pid=c539) not found.

2019-12-06T19:59:24 I cue.hid_device_detector: DeviceInstance(Path: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col05#9&252ce42a&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}", InstanceId: "hid\\vid_1b1c&pid_1b50&mi_00&col05\\9&252ce42a&0&0004", ParentInstanceId: "USB\\VID_1B1C&PID_1B50\\0F025029AF0894C658B2EC47F5001944\u0000") inserted.

2019-12-06T19:59:24 I cue.hid_device_detector: Add open task: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col05#9&252ce42a&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}" with delay 0 ms.

2019-12-06T19:59:24 I cue.devices: Device vid=1b1c pid=c10 ignored by HidDeviceEnumerator

2019-12-06T19:59:24 C cue.hid_device_detector: Failed to open: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col01#9&252ce42a&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}\\kbd"

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col02#9&252ce42a&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col06#9&252ce42a&0&0005#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col03#9&252ce42a&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col04#9&252ce42a&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 I cue.hid_device_detector: "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col05#9&252ce42a&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}" opened.

2019-12-06T19:59:24 I cue.hid_device_detector: Mark all tasks as finished.

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col06#9&252ce42a&0&0005#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2019-12-06T19:59:24 I cue.devices: Created new device"K63 WIRELESS" (vid=1b1c, pid=1b50); ready:false

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_01#9&d6957e5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_01#9&d6957e5&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col02#9&252ce42a&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col02#9&252ce42a&0&0001#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col03#9&252ce42a&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col03#9&252ce42a&0&0002#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col04#9&252ce42a&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col04#9&252ce42a&0&0003#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 0

2019-12-06T19:59:24 I cue.devices: Begin attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col05#9&252ce42a&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}" status b= 0

2019-12-06T19:59:24 I cue.devices: End attaching to "K63 WIRELESS" (vid=1b1c, pid=1b50) "\\\\?\\hid#vid_1b1c&pid_1b50&mi_00&col05#9&252ce42a&0&0004#{4d1e55b2-f16f-11cf-88cb-001111000030}" status a= 6

2019-12-06T19:59:24 I cue.devices: Initializing "K63 WIRELESS" (vid=1b1c, pid=1b50)

2019-12-06T19:59:25 I cue.devices: "K63 WIRELESS" Received PairingId("91542590")

2019-12-06T19:59:25 I cue.devices: Initialized true "K63 WIRELESS" (vid=1b1c, pid=1b50)

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 I cue.lightings.direct_player: Started lighting worker in 0x28a8

2019-12-06T19:59:25 C cue.devices.layout: Invalid HW layout

2019-12-06T19:59:25 C cue.manifest: Cannot find "" layout for 0x10e2fb80

2019-12-06T19:59:25 W qrc:/qml/styled/CueCheckBox.qml:32: ReferenceError: viewModelInstance is not defined

2019-12-06T19:59:25 I cue.devices: Device insertion processing complete for K63 WIRELESS (vid=1b1c, pid=1b45)

2019-12-06T19:59:25 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=7)

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T19:59:25 I cue.lightings.direct_player: Started lighting worker in 0x1ee8

2019-12-06T19:59:25 I cue.devices: Device insertion processing complete for Commander Pro (vid=1b1c, pid=c10)

2019-12-06T19:59:25 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=2)

2019-12-06T19:59:25 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=7)

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T19:59:25 I cue.lightings.direct_player: Started lighting worker in 0x1754

2019-12-06T19:59:25 I cue.devices: Device insertion processing complete for Commander Pro (vid=1b1c, pid=c10)

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T19:59:25 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T19:59:25 I cue.lightings.direct_player: Started lighting worker in 0xd28

2019-12-06T19:59:25 I cue.devices: Device insertion processing complete for Commander Pro (vid=1b1c, pid=c10)

2019-12-06T19:59:26 I cue.devices.nxp: Get battery status failed. request timed out for K63 WIRELESS

2019-12-06T19:59:26 I cue.devices.nxp: "K63 WIRELESS" Get battery status failed. with "The I/O operation has been aborted because of either a thread exit or an application request. (995)"

2019-12-06T19:59:26 I cue.devices.nxp: Reset fail counter for "K63 WIRELESS"

2019-12-06T19:59:26 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T19:59:26 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::GetSecondaryChipFirmwareVersion

2019-12-06T19:59:26 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::GetLightingMode

2019-12-06T19:59:26 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::GetSecondaryChipFirmwareVersion

2019-12-06T19:59:26 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::QueryHeadsetReport

2019-12-06T19:59:26 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T19:59:26 W cue.devices.clink: "Sensor not found: vid<1b1c>pid<001c11>serial<ar5w2>index<0>senstype<Fan>sensindex<0>"

2019-12-06T19:59:27 I cue.devices: Device insertion processing complete for AX1600i (vid=1b1c, pid=1c11)

2019-12-06T19:59:27 C cue.devices.manifest: Cannot find path for manifest key (vid=1b1c, pid=1)

2019-12-06T19:59:27 I cue.sdk.device_watcher: Start prepare WorkingStateState

2019-12-06T19:59:27 I cue.sdk.device_watcher: Finish prepare WorkingStateState

2019-12-06T19:59:27 C cue.firmware.index: Incorrect index contents: fw obj is empty "combined-image"

2019-12-06T19:59:27 I cue.firmware.index: "Commander Pro" firmware update, expected version: 0.9.212 same version found, on device: bootloader: 0.5 firmware: 0.9.212

2019-12-06T19:59:27 C cue.firmware.index: Incorrect index contents: fw obj is empty "combined-image"

2019-12-06T19:59:27 I cue.firmware.index: "Commander Pro" firmware update, expected version: 0.9.212 same version found, on device: bootloader: 0.5 firmware: 0.9.212

2019-12-06T19:59:27 I cue.firmware.index: "K63 WIRELESS" firmware update, expected version: 3.12 same version found, on device: bootloader: 3.5 firmware: 3.12

2019-12-06T19:59:27 C cue.firmware.index: Incorrect index contents: fw obj is empty "combined-image"

2019-12-06T19:59:27 I cue.firmware.index: "Commander Pro" firmware update, expected version: 0.9.212 same version found, on device: bootloader: 0.5 firmware: 0.9.212

2019-12-06T20:30:25 I cue.lightings.direct_player: Stopped lighting worker in 0x1ee8

2019-12-06T20:30:28 I cue.devices: Device vid=1b1c pid=c10 ignored by HidDeviceEnumerator

2019-12-06T20:30:30 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T20:30:30 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T20:30:30 I cue.lightings.direct_player: Started lighting worker in 0x710

2019-12-06T20:30:30 I cue.devices: Device insertion processing complete for Commander Pro (vid=1b1c, pid=c10)

2019-12-06T20:30:31 C cue.firmware.index: Incorrect index contents: fw obj is empty "combined-image"

2019-12-06T20:30:31 I cue.firmware.index: "Commander Pro" firmware update, expected version: 0.9.212 same version found, on device: bootloader: 0.5 firmware: 0.9.212

2019-12-06T20:31:00 I cue.lightings.direct_player: Stopped lighting worker in 0x710

2019-12-06T20:31:02 I cue.devices: Device vid=1b1c pid=c10 ignored by HidDeviceEnumerator

2019-12-06T20:31:02 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::SetDpiBrightnessLevel

2019-12-06T20:31:02 C cue.devices: Unknown command in CLinkDeviceProtocolBase: AbstractCommand::GetLightingMode

2019-12-06T20:31:02 I cue.lightings.direct_player: Started lighting worker in 0xf70

2019-12-06T20:31:02 I cue.devices: Device insertion processing complete for Commander Pro (vid=1b1c, pid=c10)

2019-12-06T20:31:02 C cue.firmware.index: Incorrect index contents: fw obj is empty "combined-image"

2019-12-06T20:31:02 I cue.firmware.index: "Commander Pro" firmware update, expected version: 0.9.212 same version found, on device: bootloader: 0.5 firmware: 0.9.212

2019-12-06T20:34:29 I cue.core.init_ui: Starting UI.

2019-12-06T20:34:29 C cue.devices: Unknown command in NxpPhysicalHidDevice: AbstractCommand::QueryHeadsetReport

2019-12-06T20:34:29 W QObject::connect(MobileServerSettingsModel, ProgramSettingsModel): invalid null parameter

2019-12-06T20:34:30 W qrc:/qml/delegate/MarkLinedAssignmentListDelegate.qml:22:23: Invalid property assignment: int expected - Assigning null to incompatible properties in QML is deprecated. This will become a compile error in future versions of Qt.

2019-12-06T20:34:31 W MainWindow_QMLTYPE_500(0x195eda40) must be a top level window.

2019-12-06T20:34:31 W MainWindow_QMLTYPE_500(0x195eda40) must be a top level window.

2019-12-06T20:34:31 W Model size of -1 is less than 0

2019-12-06T20:34:31 W libpng warning: iCCP: known incorrect sRGB profile

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/ui/accordion/DialControlAccordionItem.qml:24: ReferenceError: itemToolbar is not defined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:32 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:35 W "Could not convert argument 0 at"

2019-12-06T20:34:35 W "updateSelection@qrc:/qml/ui/accordion/PerformanceAccordionItemContent.qml:37"

2019-12-06T20:34:35 W "onCurrentPropertyItemDeselected@qrc:/qml/ui/accordion/PerformanceAccordionItemContent.qml:84"

2019-12-06T20:34:35 W "onModelChanged@qrc:/qml/ui/accordion/PerformanceAccordionItemContent.qml:113"

2019-12-06T20:34:35 W "__selectDevice@qrc:/qml/ui/MainScreen.qml:820"

2019-12-06T20:34:35 W "onSelectedDeviceIndexChanged@qrc:/qml/ui/MainScreen.qml:1213"

2019-12-06T20:34:35 W "onDeviceSelected@qrc:/qml/ui/DevicesPanel.qml:91"

2019-12-06T20:34:35 W "onClicked@qrc:/qml/ui/deviceview/DevicesView.qml:189"

2019-12-06T20:34:35 W "onClicked@qrc:/qml/delegate/DevicePictureDelegate.qml:113"

2019-12-06T20:34:35 W "Passing incompatible arguments to C++ functions from ********** is dangerous and deprecated."

2019-12-06T20:34:35 W "This will throw a ********** TypeError in future releases of Qt!"

2019-12-06T20:34:37 W qrc:/qml/collection/ColorPicker.qml:42: TypeError: Cannot call method 'updateCurrentColor' of null

2019-12-06T20:34:37 W qrc:/qml/collection/ColorPicker.qml:48: TypeError: Cannot call method 'updateCurrentColor' of null

2019-12-06T20:34:37 W qrc:/qml/ui/settings/DeviceSettings.qml:50:11: QML ColumnLayout: Binding loop detected for property "contentHeight"

2019-12-06T20:34:37 W qrc:/qml/ui/settings/DeviceSettings.qml:238:7: Unable to assign [undefined] to double

2019-12-06T20:34:37 W qrc:/qml/JS/DropdownUtils.js:70: TypeError: Cannot read property 'rowCount' of undefined

2019-12-06T20:34:37 W qrc:/qml/delegate/TabViewTabDelegate.qml:21: TypeError: Cannot read property 'top' of null

Edited by techfiend
Link to comment
Share on other sites

Is the CoPro that disappears connected to the USB port of another CoPro?

 

Thanks for the response.

 

I'm not sure. This is a prebuilt system by Digital Storm. I'll have to remove one of the radiators to check that, which is a huge PITA but I've done it before. I know where the CoPro is located, just not sure if it's daisy chained to another CoPro or directly to motherboard usb header. Might just try disconnecting some of the motherboard usb connections to see if that specific CoPro shuts off on its own.

 

What would it mean if it is or is not daisy chained given my problem? And also why would everything work fine with LINK but not iCue?

 

Also just read that disabling selective USB suspend in Windows power settings could help. It was enabled, so hopefully disabling might help...

Link to comment
Share on other sites

Thanks for the response.

 

I'm not sure. This is a prebuilt system by Digital Storm. I'll have to remove one of the radiators to check that, which is a huge PITA but I've done it before. I know where the CoPro is located, just not sure if it's daisy chained to another CoPro or directly to motherboard usb header. Might just try disconnecting some of the motherboard usb connections to see if that specific CoPro shuts off on its own.

 

What would it mean if it is or is not daisy chained given my problem? And also why would everything work fine with LINK but not iCue?

 

Also just read that disabling selective USB suspend in Windows power settings could help. It was enabled, so hopefully disabling might help...

 

Update: It appears to be daisy chained. One of the CoPro is connected directly into the motherboard. The other two CoPros are definitely daisy chained as removing a single usb connection resulted in two CoPros disappearing from iCue. I'm just not sure which one is daisy chained to the other.

Link to comment
Share on other sites

Is the CoPro that disappears connected to the USB port of another CoPro?

 

Sorry for all the responses. Tore it apart and can confirm the problem CoPro is connected to another CoPro. Even tried plugging it into the second USB port but the problem still occurred.

Edited by techfiend
Link to comment
Share on other sites

Yeah, I've seen this. It seems to happen particularly when the system resumes from sleep.

To resolve, I plugged it into an internal USB Hub (from NZXT) that I have. Haven't had the issue since.

 

Interesting, thanks. My motherboard only has two usb 2.0 headers, so I’ll have to get this expander. Is this the one? https://www.microcenter.com/product/477290/nzxt-internal-usb-hub

Also my system never goes to sleep, I always shut it down, and this CoPro losing connection from iCue happens randomly while using the computer. Can you think of any reason this would happen in iCue but not LINK?

Edited by techfiend
Link to comment
Share on other sites

I think I figured it out! The commander pros all need to be daisy chained together and then plugged into the motherboard via a single connection. Digital Storm had commander pro 1 daisy chained to commander pro 2 and then to the motherboard, and commander pro 3 directly to the motherboard, so both of my usb 2.0 headers were occupied by commander pro connections. I swapped around some connections. Commander pro 3 has my ax1600i and some other unknown usb connecting to its two USB ports, couldn’t figure out what digital storm had plugged in there. I swapped that unknown usb connection for commander pro 2, so all 3 commander pros are now connected to the motherboard via a single usb 2.0 header. This must mean iCue has an issue with multiple commander pros connected to multiple usb headers instead of being daisy chained. Still strange since LINK never had the same problem. Made a quick video. Sorry if anything is convoluted as it’s 4am!

[ame]

[/ame]
Link to comment
Share on other sites

As DevBiker said, adding an internal hub like the NZXT helps with the random disconnects or Commander Pro's not being detected at all. I found that I couldn't use the USB ports of a CoPro when the CoPro was directly connected to the USB 2.0 internal header. Apparently it seems to be some sort of enumeration conflict with ASMEDIA 2.0 hubs used my many of the motherboard manufacturers (and yes, MSI use them) and has never been resolved. I ended up buying an internal USB 2.0 hub similar to this from ModDYI (I can confirm that the NZXT hub worked but it was too bulky) and have both of my CoPro's connected via it. Once that was done, Windows was able to enumerate the CoPro's USB ports and allowed them to used without issue. On a side note, I have inline 10kΩ temperature probes connected to each of my CoPro's reading my loop temperature so even if I do lose USB communication, my fan curves remain in effect nor do I get the fans blasting at boot time.

 

PS. Sweet rig techfiend - I thought my rig was heavy with full height case & 3 rads but yours...

Link to comment
Share on other sites

  • 2 weeks later...
As DevBiker said, adding an internal hub like the NZXT helps with the random disconnects or Commander Pro's not being detected at all. I found that I couldn't use the USB ports of a CoPro when the CoPro was directly connected to the USB 2.0 internal header. Apparently it seems to be some sort of enumeration conflict with ASMEDIA 2.0 hubs used my many of the motherboard manufacturers (and yes, MSI use them) and has never been resolved. I ended up buying an internal USB 2.0 hub similar to this from ModDYI (I can confirm that the NZXT hub worked but it was too bulky) and have both of my CoPro's connected via it. Once that was done, Windows was able to enumerate the CoPro's USB ports and allowed them to used without issue. On a side note, I have inline 10kΩ temperature probes connected to each of my CoPro's reading my loop temperature so even if I do lose USB communication, my fan curves remain in effect nor do I get the fans blasting at boot time.

 

PS. Sweet rig techfiend - I thought my rig was heavy with full height case & 3 rads but yours...

 

Wanted to report back that after over a full week the problem has not returned! I was ready to get a usb hub but thankfully daisy chaining the three together has fixed the issue.

 

That’s a good idea to use the temp probes in that manner. I think digital storm didn’t place the probes well, sort of put them all together in a couple spots. Can you explain more about where the probe is exactly in your loop?

 

Also thanks about the rig. I went all out on a pure gamer build.

Link to comment
Share on other sites

 Share

×
×
  • Create New...