Jump to content
Corsair Community

TX650 Fan Super Loud? Stuck on 100% when under low load.


warfare238
 Share

Recommended Posts

I have a TX650, and I heard the fan was supposed to be very quiet/silent, but my fan spins at a constant 100% (I unplugged my GPU and CPU power, it stayed at 100%). Is there a way I can fix the fan speed or noisiness?

 

To put it into context, it is about twice as loud as my CPU cooler under barely any load.

 

Thanks for your time!

Link to comment
Share on other sites

  • Corsair Employees
I have a TX650, and I heard the fan was supposed to be very quiet/silent, but my fan spins at a constant 100% (I unplugged my GPU and CPU power, it stayed at 100%). Is there a way I can fix the fan speed or noisiness?

 

To put it into context, it is about twice as loud as my CPU cooler under barely any load.

 

Thanks for your time!

 

Sounds like the fan controller died. :(

 

It should vary based on temperature.

 

I would have it replaced with a new unit.

Link to comment
Share on other sites

Interestingly, my TX650M turned up today and I have the exact same issue.

 

I did the paperclip test with nothing connected so no load on the power supply and the fan was still at what seemed like 100% speed. Roughly 50db.

 

I wonder if there has been a bad batch???

Link to comment
Share on other sites

  • Corsair Employees
Interestingly, my TX650M turned up today and I have the exact same issue.

 

I did the paperclip test with nothing connected so no load on the power supply and the fan was still at what seemed like 100% speed. Roughly 50db.

 

I wonder if there has been a bad batch???

 

If there was a bad batch, Corsair would know about it already.

 

Only two examples so far (your and the OP).

 

You should contact Corsair support.

Link to comment
Share on other sites

 Share

×
×
  • Create New...