Jump to content
Corsair Community

H2100 Headset stopped working... kinda


bernardirafael
 Share

Recommended Posts

Hello!

 

Yesterday I was using my Corsair H2100 normally, when all of a sudden no audio came out of it.

 

The dongle seems fine, when I plug it in the USB port (tried at least 3 ports) the computer identifies it (and even installed the drivers for it when I connected the dongle in another computer) and switches automatically to the headset as current device.

The headset, which is fully charged, also turns on. However, I can't hear that static noise when it is on... and the volume selector does not works. It's like both headset and dongle are not paired anymore.

 

I did the pairing procedure: with headset off, I pressed that tiny button in the dongle until it starts blinking quickly. Then, I turn the headset on until its LEDs also start blinking quickly. Both keep blinking and, apparently, cannot pair.

 

I tried to use the headset in another computer. It doesn't works.

 

Is it dead?

 

Thank you in advance!

Link to comment
Share on other sites

 Share

×
×
  • Create New...