Jump to content
Corsair Community

Messed shortcuts after update


Shait
 Share

Recommended Posts

Hello,

 

today I have updated iCue to version 3.22.74 and now suddenly when I hit F1 it open Mozzila Firefox and also Windows help screen. F2 open Winamp and F3 open search. It's very annoying during gaming sessions, because it minimize my game and I cannot use these keys anymore. I cannot figure how to disable this, in previous version this never happened. I have K95 RGB Platinum keyboard.

 

I would appreciate any help.

Edited by Shait
Link to comment
Share on other sites

New issue - calculator also open whenever I press ESC key. All these issues are go away if I quit iCue. This is definitely problem with last version, I just tried previous version and everything works fine! But my profiles get corrupted when I roll back version of iCue.
Link to comment
Share on other sites

I didn't had any macros. Only launch programs on G1 calculator, G2 Firefox and G3 Winamp. I think they were mixed with F1-F3 after update. No idea why it also affected ESC key.

 

For now I have rolled back to previous version and created new profiles.

Link to comment
Share on other sites

I didn't had any macros. Only launch programs on G1 calculator, G2 Firefox and G3 Winamp. I think they were mixed with F1-F3 after update. No idea why it also affected ESC key.

 

For now I have rolled back to previous version and created new profiles.

 

In 3.2274, go to your Actions Library and delete those 3 G-keys assigns. Not the actual profile actions, but the Library down below. I have been playing with this issue and it is possible you may need to delete the profile actions and then redo them. As long as you keep the Actions Library empty, you should not get the F-keys picking up the G key assignments. Yes, it is weird.

Link to comment
Share on other sites

The escape key I did not have issues with. Is the calculator bound to anything through a BAT file or other macro? I spent quite a few hours going back and forth between 3.22 and 3.21, loading and deleting different profiles and clean profiles from other time periods. Since I deleted the Actions Library, it has never happened again. I am confident in that resolution. However, the calculator is a bit of a mystery.
Link to comment
Share on other sites

As far I remember I picked calculator from launch application and then select it from list. But it was bind to G1 not Esc. What is weird, my friend also have issue with F1 launching internet browser, but he had nothing in macros at all.
Link to comment
Share on other sites

I forgot there is a designated launch selector in Launch App menu. I can replicate this. When bound to G1, it will cause the same issue -- no library setting required. There are some G key bugs in this version. If you really need it, try G6 or use a standard Windows shortcut from the desktop/start menu for the time being. Or just stay on 3.21.
Link to comment
Share on other sites

  • 1 month later...
I had a similar issue this morning with my brand new K95. I had bound G3 to Open File Explorer, but the Escape key was doing this as well, even though it was clearly unbound in iCUE. By removing the Open File Explorer entry I'd created in the Action Library, the problem went away. When I recreated it in the Action Library, even if I didn't pull it up to an Action or assign it to a key, the problem came back. Weird.
Link to comment
Share on other sites

I created an account just to post this for you all, since I've been following this thread (as well as a few others) since I first experienced the issue with iCUE causing issues with my Esc key.

 

I was finally able to resolve this by simply creating a custom rebind using iCUE to force the Esc key to rebind itself as the Esc Key. Sounds kind of silly and obvious... but it worked. Whatever bug iCUE has can be bypassed by using iCUE to rebind the Esc key to itself. Hope this helps you guys!

Link to comment
Share on other sites

  • 1 month later...
Thanks a bunch. This worked for me. I was banging my head for a while on this one. It was so weird, I had also thought of the rebind but couldn't figure out how to find the Esc key function. For those that were having the same issue. You first need to create a new action by (obviously make sure that you are editing the keyboard first), then go to the <ACTIONS> menu and Create a new action by pressing the "+" in the Action section title bar. Then select that new action in the list and click on the Esc key shown in the image of the keyboard. Then, go to the bottom of iCue interface and click the drop-down menu and select the "REMAP" > "NUM & SYMBOL KEYS", Then in the Settings section below, choose "Escape" in the bottom row. Enjoy your renewed sanity of not having to close a million open calculators in the background until Corsair fixes this bug.
Link to comment
Share on other sites

 Share

×
×
  • Create New...