Jump to content
Corsair Community

Corsair Void PRO RGB Wireless LED/charging problems


Recommended Posts

I've had it for about a week now and until earlier today it seemed to be okay. I had to charge it last night but I was in the middle of something in an MMO so I plugged it in while in use so I could keep using the headset to listen/talk.


I have it in a USB port that doesn't charge while the computer is off so I figured it would charge this morning while I did other stuff online and I noticed the charging LED did not light up at all. I had the other RGB brightness turned down to save battery and I found out when I turned it up a little, it actually seemed to make the charging LED turn on. This is not where the strange behavior ends.


I've tested with other colors and almost all of the colors you can set with icue, most don't show up correctly on the headset, either displaying as red or nothing at all. For example, if I set it to white, it only shows red. Only one specific shade of green and blue work and when I choose those specific shades, the charging led lights up. The charging led also lights up for one specific shade of red but none of the other reds.


Because of the charging led not working correctly I have unplugged the headset occasionally to check the charge level in icue and it has displayed lower percentages later on after displaying a higher percentage earlier.


Did something just break with the headset? I've tried forcing a firmware update and resetting the headset like I've read about trying to fix other problems but nothing has worked. I've seen posts about similar issues but nothing quite exactly like mine. I feel like I should just abandon trying to solve whatever is going on and try to do an exchange at Best Buy while I'm still in the window to do so. Thanks.

Link to comment
Share on other sites


  • Create New...