Jump to content
Corsair Community

Been away from the forums for a while


MrPace
 Share

Recommended Posts

I have a Corsair One 2017 model (z270I MB, MS-7A66, CS-9000009)

 

I have never updated the BIOS. Can someone post the link in this thread to the correct BIOS update for my machine on this forum? I know there was one released back in May 2018 I believe...but now I think I see one released last month?

 

Do I only need to update using the most recent one, given I've never updated this PC?

 

If anyone could post the link to the correct bios update for my model, I would appreciate it greatly! It's a little confusing at this point, and I want to make sure I'm using the correct update.

 

Thanks!

Edited by MrPace
Link to comment
Share on other sites

Here ya go. This is the one and only most up to date for our 2017 C1 BIOS =).

 

http://downloads.corsair.com/Files/Corsair-One/CORSAIR_ONE_Z270_Spectre_Update.zip

 

This is it, but only do this if you know what to do, remember if this process isn't done correctly it could lockup your motherboard. If you're not confident in what to do then better off maybe just downloading the Corsair Update utility.

 

 

EDIT *** My apologies, there is a new version of the bios you were right I just saw a link for it here on the forums up top. I wasn't looking in the forum I was just looking on the downloads support page for the C1. That's not right that it is only offered here through the forum. Corsair, this needs to be addressed, it looks like the BIOS update from 2018ish is still the most recent on the downloads support page for Corsair One 2017/2018.

Edited by zguy85
Link to comment
Share on other sites

Here ya go. This is the one and only most up to date for our 2017 C1 BIOS =).

 

http://downloads.corsair.com/Files/Corsair-One/CORSAIR_ONE_Z270_Spectre_Update.zip

 

This is it, but only do this if you know what to do, remember if this process isn't done correctly it could lockup your motherboard. If you're not confident in what to do then better off maybe just downloading the Corsair Update utility.

So downloading this file, it looks like it's from 2018.

 

The thread I linked to above is from last month. And, judging by the description and photos, it appears it would be for my Corsair One...yes?

Link to comment
Share on other sites

Posted an EDIT update to my last post. Yes there is a link on up-top the main C1 forum page that what you want to download for the most current (4.C3 update) If you need help after that let me know I'll walk you through it. That's not right that you have to get the dam update from the forum and cant get it from the support page which is where I got you that previous info. Edited by zguy85
Link to comment
Share on other sites

ok, so I updated the bios from the sticky thread (October 2019) on this forum...curiously the date on the bios screen displays 6/2019....I would have thought it would say 10/2019??

 

I downloaded the bios file from the direct download link on that sticky October 2019 thread...

 

It does say 4C3 on the bios though, so I guess I'm good.

Edited by MrPace
Link to comment
Share on other sites

Nice good to hear your set. I had problems booting after the update. Through trial and error I found I had to have the XMP option enabled. It was disabled after the BIOS update. After enabling XMP on the BIOS it worked fine. I also had to redo the boot priority order which also a funny thing, it didn't recognize my NVME Samsung 970 Plus until a few reboots also preventing it from booting, but after enabling XMP it seemed to pick it up. Haven't had an issue since. Edited by zguy85
Link to comment
Share on other sites

Yes, I also had a few scary moments during the second phase of the update (M-Flash). On one of the reboots, I got nothing but a blank screen...you know how that feels...lol

 

Luckily, I was able to turn off the PC after waiting a good while, and was able to boot back into bios and initiate the M-Flash process again, and it worked.

 

I take it XMP isn't enabled by default? So I've been running all this time with slower memory than i should be?

Link to comment
Share on other sites

 Share

×
×
  • Create New...