Jump to content
Corsair Community

Endless ICUE problems... help?


jmikes99
 Share

Recommended Posts

So I'm currently at the point where after 4 hours of dealing with iCue I have fully given up on trying to get it to work on my own and now want to know if there's ANYTHING that I can do to get this damn program to run.

 

Basically, today for whatever reason iCue wouldn't initialize any settings to my hardware. The icon was in the tray, but nothing would bring up the program (neither restarting the process nor the "click to bring to foreground" stuff.)

 

After attempting repairs and reinstalls and uninstalls and force deletes and more, any time I have the program installed, the iCue.exe process runs but no icon shows up in the tray, and I cannot open it through any means. Below is the list of things I have tried, please read it before responding so you know whether or not your solutions would help me.

 

Also to note, my Keyboard and Headset seem to be screwed up a bit from this too. Neither product's volume adjust keys do anything right now and my Keyboard won't update lights for Caps/Num lock.

 

"Solutions" I've tried:

1. Reinstalling the program

2. Fully uninstalling, deleteing all data via CCleaner and Regedit, restarting, and re-installing

3. Attempts at installing multiple different versions after clean uninstalls each time

4. Installing in different folders and in different drives

5. Launching iCue as administrator

6. Unplugging all Corsair products and using crap products I had lying around and then attempting to install iCue

7. Manually moving the full Corsair folder from Program Files 86x to Program Files

8. Disabling iCue in startup and manually clicking the exe after startup

9. Disabling all Anti-Virus programs and Windows Firewall before installing AND attempting to launch the program

10. Attempting to launch iCue in Safemode

11. Attempting repairs through the installers

12. Closing every single non-essential program on my computer and trying to run iCue

13. Doing full scans from both MalwareBytes and Kaspersky to ensure no malware is causing this

14. Running multiple disk benchmark / diagnostics tools to ensure it's not a problem with my drives

 

 

There isn't jack that's worked so far in trying to fix it and it'd be a pain in the *** for me to have to live without my custom-tuned DPI settings and all my Headset settings. I just need other potential solutions. No, I'm not reinstalling Windows or doing any crazy multi-hour long processes that shouldn't be required to be able to use a single piece of software.

 

System Info:

OS: Windows 10 Pro 64-bit

Mouse: Corsair Nightsword RGB

Headset: Corsair Void Pro RGB

Keyboard: Corsair K55 RGB (planning to upgrade during the holidays)

Windows and all drivers for all other hardware are up to date.

Edited by jmikes99
Link to comment
Share on other sites

I understand your frustration. That being said, do you remember what the last thing you did was before it stopped working?

Do you have a Windows Recovery point from a date where everything worked by any chance? This isn't listed with the things you tried.

Link to comment
Share on other sites

No, I'm not reinstalling Windows or doing any crazy multi-hour long processes that shouldn't be required to be able to use a single piece of software.

 

There's a possibility that something within Windows itself (either a recent update, or a system file getting corrupted as this can happen randomly because Windows is a butthole) so in that case you may not have any choice. Back up your data! The time I spent hearing that for 2 years straight in school and all the times I had to deal with multiple Windows re-installs and completely broken computers myself I definitely don't recommend living dangerously if you have anything important saved on your computer.

 

Sorry for the rant. Just keep in mind that, despite all other best efforts, sometimes Windows just sucks.

Link to comment
Share on other sites

Update: Tried any additional solutions that were suggested or found online, but I just said "screw it" and did a Windows reset. iCue works again.

 

Isn't directly Corsair's issue I don't think, a couple other programs refused to work too.

Link to comment
Share on other sites

 Share

×
×
  • Create New...