Jump to content
Corsair Community

Virtuoso SE and ST100 not compatible by cable


Faety
 Share

Recommended Posts

Hello !

I bought a ST100 yesterday and everything works perfectly except with the cable.

When I plug the cable to the ST100 and my Virtuoso, only the sound works. The micro doesn't work at all.

There are no problems by wireless.

Did you have the same issues ?

Edited by Faety
Link to comment
Share on other sites

I am testing something out and I think it has something to do with ICUE.

 

If the system has ICUE installed.

 

Make sure the cable to the ST100 is connected to a blue USB 3.0 port on your pc, same with the dongle, Something with ICUE might be blocking the mic from working cause I plugged in the SE into a PC USB 2.0 slot without ICUE and the mic works fine there.

 

You can also uninstall ICUE or try it on another computer that doesn't have ICUE on it to test too.

Link to comment
Share on other sites

  • Corsair Employees
Hello !

I bought a ST100 yesterday and everything works perfectly except with the cable.

When I plug the cable to the ST100 and my Virtuoso, only the sound works. The micro doesn't work at all.

There are no problems by wireless.

Did you have the same issues ?

 

What motherboard are you using? I just tested this out on my test bench, no issues on all the USB ports.

 

Also, make sure all of your USB drivers and BIOS are up to date.

Link to comment
Share on other sites

If you want to go down that road, I highly recommend ASUS Motherboards. I've used them for 10+ years and have yet to have an issue with them. My Current board is a Maximus X Code, really nice , great VRM and slick OC features. Not to mention great support RGB, 2 ARGB headers which is great.
Link to comment
Share on other sites

 Share

×
×
  • Create New...